1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Transfer to vps and 500 Error

Discussion in 'XenForo Questions and Support' started by -Andromeda-, Aug 29, 2015.

  1. -Andromeda-

    -Andromeda- Active Member

    Hello everyone...

    We transferred our website to VPS. Copy all files and sql databases and import a new server.. Wordpress and MyBB is work but XenForo isn't work. XenForo isn't open because we have 500 internal server error

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@********* and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Apache/2.2.31 (Unix) mod_ssl/2.2.31 OpenSSL/0.9.8e-fips-rhel5 mod_bwlimited/1.4 Server at *************.**** Port 80
     
  2. MattW

    MattW Well-Known Member

    You need to look in the apache error logs to see why it's failing to load.
     
  3. -Andromeda-

    -Andromeda- Active Member

    My old hosting is litespeed but my new server is apache.. I do not have SSH console access privileges how can ı look ;?


    [Sat Aug 29 17:48:47 2015] [alert] [client 85.97.153.18] /home/***/public_html/.htaccess: Invalid command 'SecFilterEngine', perhaps misspelled or defined by a module not included in the server configuration, referer: ******

    *** is site url
     
  4. JustinHawk

    JustinHawk Active Member


    Have you tried changing permissions of xenforo folders and and files as I got this error too but got it fixed after changing xf file and folder permissions :)
     
  5. -Andromeda-

    -Andromeda- Active Member

    Hello there

    Thank you for the answer. I will try and write the results
     
    JustinHawk likes this.
  6. MattW

    MattW Well-Known Member

    You need to edit the .htaccess file, and remove the section with the SecFilterEngine
     
    JustinHawk and -Andromeda- like this.
  7. -Andromeda-

    -Andromeda- Active Member

    Hello there improved error. Emanating from an .htaccess code, but until there is one more question. Previously the system was opened so now forum.hayalet.web.tr How can I uninstall the opening of www as www.forum.hayalet.web.tr
     
  8. Tracy Perry

    Tracy Perry Well-Known Member

    You need to modify the .htaccess to rewrite any inbound www attempts to strip it and direct it to the non-www (if I am understanding what you are wanting to do).
    Code:
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^www.example.com$ [NC]
    RewriteRule ^(.*)$ http://example.com/$1 [R=301,L]
    
    at the top (below the rewrite on option) should work - just change the example.com to your domain.
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

Share This Page