Thread Reply Banner

Thread Reply Banner 2.4.2

No permission to download

Xon

Well-known member
Xon submitted a new resource:

Thread Reply Banner - Displayed per-thread banners above the editor for users.

Displayed per-thread banners above the editor for users.

Features:
  • Displays in both Quick Reply, and preview reply views.
  • Only fetches the thread reply banner when viewing a thread that can be replied to.
  • Text may be up to 65536 characters long, and supports bbcode.
  • Logs modifications of these banners to the Moderator Logs.
New Permission to control who can manage and see reply banners.
  • View Thread Reply Banner - default - to users/groups who can reply...

Read more about this resource...
 

Sunka

Well-known member
When you set banner and after that you delete it (delete text of banner), when you than click to save, it show error "Please enter valid banner text".
So, how to delete old banner text except make it not active?
 

Sunka

Well-known member
Also, can we change background of banner?
What is it unique class to change that in extra less?
 

doublespaces

Well-known member
Can someone give me examples of how this would be used? So is the first post simply duplicated and anchored to the reply areas? I can see how this would be useful for warnings and reminders, but simply duplicating the first post, I'm having a hard time thinking of good uses for that.
 

Xon

Well-known member
It doesn't duplicate the post, the screenshot was just demonstrating how it look.

On my forums we use this to notify users of thread policy and tell them to behave before replying
 

loplo

Active member
There are some issues, similar to what happened with @XenConcept User Activity before he upgraded his resource.
On UI.X based themes,
- the thread reply banner is being duplicated in the titlebar
1519980997440.png

- while browsing on a mobile device the duplicated banner is shown as an overlay, making unable to see the thread content.
1519981222875.png

- the reply banner is not wrapped (on mobile devices), right above quick reply
1519981427101.png

cc @ThemeHouse @Ian Hitt
 

Ian Hitt

Well-known member
@Xon If you do not already have a copy of UI.X I can get you set up with a free license. Otherwise if you'd prefer you can send me a copy of Thread Reply Banner and I can try and figure out why the template modification is targeting the titlebar. If I had to take a quick guess, I would assume that the issue may lie with the fact that we add an <xf:pageaction /> to thread_view in the titlebar.
 

Xon

Well-known member
@Xon If you do not already have a copy of UI.X I can get you set up with a free license.
That would be great but it may be a bit of time before I can organised that on my-end todo anything about it.

Otherwise if you'd prefer you can send me a copy of Thread Reply Banner and I can try and figure out why the template modification is targeting the titlebar. If I had to take a quick guess, I would assume that the issue may lie with the fact that we add an <xf:pageaction /> to thread_view in the titlebar.
This is a free add-on available on my github profile; https://github.com/Xon/XenForo2-ThreadReplyBanner I accept pull requests :D

I'm fairly busy, so if you could have a look that would be great. I know the css/html was a quick & dirty job, and I've got a vague idea on the issue.

Could you also see if my User Activity add-on causes issues? https://github.com/Xon/XenForo2-UserActivity/tree/2.1.x Note; master should be workable but it isn't feature complete compared to User Activity for XF 1.6.x
 

Ian Hitt

Well-known member
Unfortunately, add-ons are not my forte personally, I am a UI developer :) But I can try and find the offending template modification so that it is easier for you to resolve the issue. If you do not already, feel free to create an account at https://www.themehouse.com/ and then PM me with your username and I will add a UI.X 2 license to your account.
 

Pinn

Active member
Bug??

Code:
Fatal error: Access level to SV\ThreadReplyBanner\XF\Pub\Controller\Forum::setupThreadCreate() must be public (as in class QuestionThreads\XF\Pub\Controller\Forum) in /www/xxxxxxx/xxxxxx/xxxxxxxxx/src/addons/SV/ThreadReplyBanner/XF/Pub/Controller/Forum.php on line 26
 

Xon

Well-known member
Bug??

Code:
Fatal error: Access level to SV\ThreadReplyBanner\XF\Pub\Controller\Forum::setupThreadCreate() must be public (as in class QuestionThreads\XF\Pub\Controller\Forum) in /www/xxxxxxx/xxxxxx/xxxxxxxxx/src/addons/SV/ThreadReplyBanner/XF/Pub/Controller/Forum.php on line 26
You have @CMTV's QuestionThreads add-on?

This is a bug in their add-on, where they have re-defined setupThreadCreate as public instead of the original protected. Not this add-on
 

CMTV

Well-known member
This is a bug in their add-on, where they have re-defined setupThreadCreate as public instead of the original protected.
Thanks for the info!
This is fixed (among many other bugs) in a new upcoming update.
 

CMTV

Well-known member
I am sorry. Thought you were talking about this post and didn't even notice that you are asking a different person...
 
Top