1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 There was an error uploading your file.

Discussion in 'Troubleshooting and Problems' started by Nicky Vermeersch, Aug 11, 2015.

  1. Nicky Vermeersch

    Nicky Vermeersch Active Member

    It happens a lot when trying to upload attachments or images to the media gallery. I increased the following options in php:
    • upload_max_filesize=800M
    • post_max_size=800M
    • max_execution_time=300
    • max_input_time=300
    However I still get "There was a problem uploading your file." as an error. I'm using CentOS 6.6, php-fpm and nginx. Could this be somehow related to nginx?

    edit: Ugh, I feel so retarded now. I forgot about nginx at all. I added client_max_body_size to the http block in nginx.conf, restarted both php-fpm and nginx and now it works fine.
     
    Last edited: Aug 11, 2015

Share This Page