1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 "The uploaded file does not have an allowed extension"

Discussion in 'Troubleshooting and Problems' started by Temery, Feb 23, 2016.

  1. Temery

    Temery Active Member

    image.png image.png I now get this message, even with graphics I've used previously.

    Any idea why?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    What is the extension of the file and is it an allowed extension in Options -> Attachments: Allowed Attachment File Extensions ?
     
  3. Temery

    Temery Active Member

    Not sure. Whatever a screen capture on an iPad saves as a a file extension. I've done so before without a problem.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    I don't own an iPad so I wouldn't know.

    It sounds like the extension isn't in the allowed list though, whatever it is.
     
  5. Chris D

    Chris D XenForo Developer Staff Member

    It may be worth trying to upload it to this forum to see if it works here; that will also tell you what the extension is.

    Also what version of iOS is the iPad running? I vaguely remember some weirdness in the past with iOS and file extensions but I don't recall seeing it recently.
     
  6. melbo

    melbo Well-Known Member

    Pretty sure iOS screenshots are .png
     
  7. MDaly

    MDaly New Member

    I am having similar issue - unable to upload .scad files but it is most definitely on the allowed list of extensions. I even tried removing and replacing it on the allowed extension list but it still will not upload. Same as here on the forum.
     
  8. Snog

    Snog Well-Known Member

    Make sure you don't have the . in the allowed extension list (as in .scad should just be scad). I can upload scad files without a problem on my development server.

    scad.png
     
  9. MDaly

    MDaly New Member

    I do not have the dot. Here is a screenshot of the setting. Attachment Extensions Allowed.PNG
     
  10. Chris D

    Chris D XenForo Developer Staff Member

    Does it make any difference if scad is the only extension in the allowed list?

    And can you confirm the exact error message?
     
  11. MDaly

    MDaly New Member

    Appreciate the assist although no closer to a solution. I modified the options to only allow SCAD and still got the error when I attempted to upload the file.

    SCAD Upload Error.PNG
    Attachment Extensions Allowed_SCAD ONLY.PNG
     
  12. Chris D

    Chris D XenForo Developer Staff Member

    I'm struggling to come up with a logical explanation for this right now.

    Just to confirm: Is this error happening when attempting to upload the file to a post on the forum? Or is it happening in an add-on e.g. Resource Manager? If the latter, then the RM has its own allowed extensions list. Also any other add-ons may have their own list of allowed extensions also.

    If it's in a forum post it may be wise to disable all add-ons and try again, just in case there's an add-on that has started to cause a problem here.
     
  13. MDaly

    MDaly New Member

    You bring up a good point Chris D. The issue specifically lies within attachment to Xenzine articles. There are no settings (that I can find) specific to Xenzine file attachment types. Looking around, it seems this add-on is no longer supported by the author.:(
     
  14. Chris D

    Chris D XenForo Developer Staff Member

    If the scad file uploads to a normal forum post then yes that would likely explain it.

    You could post in the resource thread support. Other users of the add on may have solved the same issue.
     

Share This Page