1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Text Editor Auto-Disable on IE

Discussion in 'XenForo Questions and Support' started by kevinchan, Nov 22, 2013.

  1. kevinchan

    kevinchan Member

    Hi Guys,

    May i know if anyone encountered this error? My forum is running on Xen verson 1.2, there are no any upgrade processes before. When i use Google Chrome & Firefox, the text editor displayed very well. However, when i used IE, the Text Editor seems disable. I was unable to type anything on it. Moreover, the Text control menu in Text editor disappeared as well.

    Here is the display of Text editor in my forum:

    IE ERROR.jpg

    I have tried to disable all the Add-ons, its is still the same. But before when i done with the set up for my forum, it is still displayed very well on IE. Idid use the "File Health Check" function and it is showing fine.

    Can anyone help me on this?

    Thanks!
     
  2. Mike

    Mike XenForo Developer Staff Member

    Check if it works on the default style on your site (and confirm that it's working here in IE as expected).
     
  3. kevinchan

    kevinchan Member

    Hi @Mike ,

    Thank you for a fast support, it is not working in default style as well. Could u tell me which templates that i have to revert it? I will try it.

    Thanks.
     
  4. Amaury

    Amaury Well-Known Member

    If you disable your add-ons, does it work?
     
  5. kevinchan

    kevinchan Member

    It is still the same...Amaury... :cry:
     
  6. Amaury

    Amaury Well-Known Member

    Is the issue here on XenForo Community as well? If it is, then it may be a bug.
     
  7. kevinchan

    kevinchan Member

    As I was mentioned on the first post, after installed the forum, everything is working fine in IE, but I don't know why suddenly it was happened like this on my forum.

    The issue is not happened here in Xenforo Community...

    Anyway, Could u tell me which templates that i have to revert it? I will try it then.. thanks
     
  8. Amaury

    Amaury Well-Known Member

    Well, if it isn't working in the default style, as you mentioned, then it's not a style issue.

    Your best bet would probably be to submit a ticket or send a PC to @Mike with FTP and admin CP access.
     
    kevinchan likes this.
  9. kevinchan

    kevinchan Member

    Yes, Amaury, i'm goin' to do so... Anyway, thank you! :)
     
  10. Jeremy

    Jeremy XenForo Moderator Staff Member

    If you open the JavaScript console, do you see any errors?
     
  11. kevinchan

    kevinchan Member

    Hi Jeremy, could u tell me how can i open the JavaScrip console?
     
  12. kevinchan

    kevinchan Member

    The first screenshot in the first post is the error shown on IE version 10...

    I have tried to test on IE 8.0. I'm able to see the Text control menu and also able to type on it. However, i didn't see the "Use Rich Text Editor" or "Use BBcode Editor" (below the "Text Editor Box"):

    Here is the display on IE 8.0:

    Rich_editor.JPG

    Actually, i was translate the phrase: "Use Rich Text Editor" and 'Use BBcode Editor" to other language, but it will not affected to the forum as the english version is still there.

    Really couldn't figure out what are the causes...

    Thus, i have reported to Xenforo Support team.

    Thanks!
     
  13. kevinchan

    kevinchan Member

    Hi Mike & All,

    I have upgraded the Forum to Xen 1.2.3 and the issue is fixed.

    Thank you! :)
     

Share This Page