• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

Tenshi - Latest Thread - Sidebar

Atakan KOC

Active member
#1
This will latest x thread on to your forum sidebar.

Install
Step 1
Upload the contents of "library" to your XF root directory

Step 2
Import the XML product through your Admin CP
Admin CP > Home > Install Add-On > Select 'addon_tenshi_latest_thread.xml'

Step 3
Find your "forum_list" template to include the new sidebar item

Admin CP > Appearance > Templates > Search for forum_list > Click forum_list to edit it

Search the template and find:
Code:
</xen:sidebar>
Right above it add:
Code:
<xen:include template="tenshi_latest_thread"></xen:include>
 

Attachments

Trip

Active member
#5
This is great! I missed this function is the sidebar after the import to xF (can't wait to try it out). I saw a couple of posts with members requesting this and I hoped someone would take the time to write it.
Thanks for coding this Tenshi :)
 

kkm323

Well-known member
#8
I am loving this
so simple and great
thanx
ps do you think you can release
  • top posted/likes member in x days
 

Trip

Active member
#9
I get a little template error on my localhost testserver.
Code:
Argument 1 passed to XenForo_Template_Helper_Core::helperRichUserName() must be an array, null givenin C:\xampp\htdocs\xenforo\library\XenForo\Template\Helper\Core.php, line 766

Points it at the template forum_list I don't think I messed up the edit...I'm in debug mode, don't know if that makes a difference or not.

</div>
<xen:include template="tenshi_latest_thread"></xen:include>
</xen:sidebar>
 

JVCode

Well-known member
#10
I get a little template error on my localhost testserver.
Code:
Argument 1 passed to XenForo_Template_Helper_Core::helperRichUserName() must be an array, null givenin C:\xampp\htdocs\xenforo\library\XenForo\Template\Helper\Core.php, line 766

Points it at the template forum_list I don't think I messed up the edit...I'm in debug mode, don't know if that makes a difference or not.

</div>
<xen:include template="tenshi_latest_thread"></xen:include>
</xen:sidebar>
I'm getting the same problem on localhost, but it only appears when in debug mode.
 

bambua

Well-known member
#11
My only question, and it's the stumbling block I've run into on my version of this, is does it take in to account the view permissions of the current user?

I've got this same addon about 3/4 done I'm just working on the permissions end of it.