1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Template titles must be unique. The specified title is already in use.

Discussion in 'Troubleshooting and Problems' started by mrb1972, Aug 13, 2013.

  1. mrb1972

    mrb1972 Active Member

    I have created a 1.2 style on my test board but when I try to import it to my live 1.2 site I get the error

    Template titles must be unique. The specified title is already in use.

    I only have the default style installed on my live site, anyone know how to fix the problem or tell which template it thinks is already in use?

  2. Brogan

    Brogan XenForo Moderator Staff Member

    Which custom templates did you create on your test installation?
  3. Mike

    Mike XenForo Developer Staff Member

    I think this may actually be an indication of something in the upgrade failing. Can you run this query via phpMyAdmin?

    SHOW CREATE TABLE xf_template;
  4. mrb1972

    mrb1972 Active Member

    Just a couple of the Default ones - Footer, Header, PAGE CONTAINER and few templates linked to an add-on I use - I used the TMS system to make the edits
  5. mrb1972

    mrb1972 Active Member

    Is this was you wanted?

  6. Mike

    Mike XenForo Developer Staff Member

    Hmm ok, that looks fine. I'm not sure how this would happen out of the box.

    However, you mentioned using TMS (the add-on, I assume), so it may very well be related to that. Try disabling it and reimporting the style.
  7. mrb1972

    mrb1972 Active Member

    Ok apologies, it's nothing to do with the default TMS system, I forgot I had installed the "bolt-on" 3rd party TMS add-on, it seems that is causing the issue, I have managed to work around it..


Share This Page