XF 1.4 Tagging/Mentions Alerts Not Always Working

TW89

Member
As per title. The vast majority of user mentions do result in alerts, but some members aren't getting all of them. I've confirmed that they don't show in the alerts page. It seems to be occurring on large threads (often 10-100 pages in length with many participants) but I'm not certain it's restricted to them.

Is this a known issue?

I did previously have a user tagging add-on (bd) that would enable users to tag certain groups such as moderators however I've now removed this and the issue persists.
 

Martok

Well-known member
There can be various reasons why alerts for mentions aren't received. If someone is watching a thread, they won't receive a mention alert as the new reply alert 'overrides' this. If someone is quoted and tagged, they'll get an alert for the quote and not the tag. If a post is edited and a tag is added afterwards, no alert will be sent. If someone tags say 10 people and the user group tagging permission is set to say 5, then only 5 people will get the tag alerts.
 

TW89

Member
There can be various reasons why alerts for mentions aren't received. If someone is watching a thread, they won't receive a mention alert as the new reply alert 'overrides' this. If someone is quoted and tagged, they'll get an alert for the quote and not the tag. If a post is edited and a tag is added afterwards, no alert will be sent. If someone tags say 10 people and the user group tagging permission is set to say 5, then only 5 people will get the tag alerts.
Thank you for explaining that, I didn't realise it worked in that way. I'm sure it's a case of the watched thread alert overriding the tag. Cheers.
 

Martok

Well-known member
Thank you for explaining that, I didn't realise it worked in that way. I'm sure it's a case of the watched thread alert overriding the tag. Cheers.
Actually I discovered that a tag/mention overrides a watch alert (unless you have the Tag Me add-on installed which reverses this behaviour. The other cases do apply though.
 

TW89

Member
Actually I discovered that a tag/mention overrides a watch alert (unless you have the Tag Me add-on installed which reverses this behaviour. The other cases do apply though.
That makes sense. I did have the tag me add-on but since I've removed it the amount of people with 'problems' have reduced.
 

TW89

Member
I do think that it would be worthwhile if XenForo could make it so that if a tag is added in an edit that it still creates an alert. Either that just make it so that tags can't be added in an edit.
 

Chris D

XenForo developer
Staff member
It's unlikely to, as nothing has changed.

It will likely be down to permissions, or adding mentions when posts are edited.
 

Recep Baltaş

Well-known member
Yeah, it was the "Maximum tag alterts" setting. I don't know how it was changed but it was changed. Reverted back to unlimited and solved. Thanks.
 
Top