I.e. "News Feed Items To Fetch With Each Request", whereas others are called "Discussions Per Page" or "Messages Per Page". They do the same, but somehow the News Feed naming is off. (Also, "Alerts-Per-Page" has hyphens in it). Why not name the option "News Feed Items Per Page" instead?
And "News Feed Message Snippet Maximum Length" essentially does the same as "Discussion Preview Length". Why not call it News Feed Message Preview Length? Or even better, a generic "Message Preview Length" that serves bost. Chances are if I configure the "Discussion Preview Length" to 200 characters, I want the "News Feed Snippet" to reflect the same number.