• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Suddenly I can't administrate

Mr Lucky

Well-known member
#1
I get into the admin control panel, but when I try to change a user's group I get this:

The following error occurred:

Forbidden
You don't have permission to access /community/admin.php on this server.


help!!! please
 

Mr Lucky

Well-known member
#4
You've changed the file permissions on admin.php. Change it back so it is 0644 I believe.
No I didn't change any permissions, it's still at 644

EDIT: I can do other things in admin, e.g. change the name of a usergroup or changea usergroup permissions

BUT the big problem is changing/adding a group for a user
 
Last edited:

Mr Lucky

Well-known member
#7
I've raised a support ticket now is this is very serious, possibly disastrous as we can't properly moderate users.
 

Mr Lucky

Well-known member
#8
Ok, I seem to have fixed it by changing admin.php from644 to 744

I'm not sure if that is a good idea though so changed it back to 644 after changing the usergroup for the user
 

Mike

XenForo developer
Staff member
#10
I responded to your ticket, but Jeremy is correct -- this is almost certainly caused by some system on your server. It's very unlikely XenForo's code is even being run before this was triggered.

(Though I wasn't able to reproduce the issue when I tested.)
 

Mr Lucky

Well-known member
#11
The problem isn't with the software and with the server itself. It sounds like you may have some mod_security settings or something server side that is sending a forbidden error.
This is something that was OK before and just started recently. Nothing changed on the server.

I changed the permissions from 644 to 744 and the problem seemed to be solved.
 

Mr Lucky

Well-known member
#12
I responded to your ticket, but Jeremy is correct -- this is almost certainly caused by some system on your server. It's very unlikely XenForo's code is even being run before this was triggered.

(Though I wasn't able to reproduce the issue when I tested.)
probably because it was after i changed the admin.php from 644 to 744
 

Adam Howard

Well-known member
#14
This is something that was OK before and just started recently. Nothing changed on the server.

I changed the permissions from 644 to 744 and the problem seemed to be solved.
If it was working on 744 .... Something changed.

That's not a usual (common) setting for a php file to need to execute. And as you said, it was working before.
 

Mr Lucky

Well-known member
#15
If it was working on 744 .... Something changed.

That's not a usual (common) setting for a php file to need to execute. And as you said, it was working before.
The only thing I can think of is I installed the add-on NRE - New Registration Email. Could that have caused this?
 

Mr Lucky

Well-known member
#17
It's highly unlikely that and add-on changed file permissions. Your host must have updated something recently or they installed something recently that caused this to happen.
No, nothing actually changed the file permissions. (Apart from me doing it manually when testing)

I checked the permissions as advised by Jeremy and found it to be still at 644, as installed. When I changed it to 744 I was again able to access the admin page for changing usergroups. Note that all along I had been able to access other admin pages, just not the one where you change a user's group.

So I changed it to 744 to see what would happen and found that suddenly it worked again.
 

Tracy Perry

Well-known member
#18
No, nothing actually changed the file permissions. (Apart from me doing it manually when testing)

I checked the permissions as advised by Jeremy and found it to be still at 644, as installed. When I changed it to 744 I was again able to access the admin page for changing usergroups. Note that all along I had been able to access other admin pages, just not the one where you change a user's group.

So I changed it to 744 to see what would happen and found that suddenly it worked again.
Check the ownership/group of it.
 

Mr Lucky

Well-known member
#19
Check the ownership/group of it.
To what?

Both are set to the username of the cpanel.

What I find weird is that I change it back to 644, and now it also works.

So it goes like this

  • Originally after installing it worked fine
  • Suddenly this weekend we get the Forbidden error
  • Check admin.php permissions following Jeremy's post above and find they are correct (=644)
  • Change admin.php to permission 744
  • Able to edit user again
  • Change back to 644
  • Still no problem
I spoke to the host, Zen Internet, who were not aware of any change to mod_security over the weekend, but offered to invsitiagte if I can replicate the issue, which at the moment i can't as it's all working fine after changing for 644 to 744 and back to 644.

Seems very strange to me.
 

Tracy Perry

Well-known member
#20
To what the other related files would be. Make sure that they all have the same ownership.

I spoke to the host, Zen Internet, who were not aware of any change to mod_security over the weekend, but offered to invsitiagte if I can replicate the issue, which at the moment i can't as it's all working fine after changing for 644 to 744 and back to 644.

Seems very strange to me.
Sound like something on the server end.... and they just "forgot" what it was but fixed it.
I don't use mod_security but if they had it to restrictive it could have caused problems.