XF 2.0 Forum suddenly went down, then came back up 30 minutes later on its own. How to troubleshoot?

CZ Eddie

Active member
This morning the site suddenly went down for no apparent reason. I had just finished restoring a backup and was about to transfer our IP to it when the original site popped back online as if nothing had happened.

Here is the error we get when we tried to access the webpage or the admin control panel:

------------
Not Found

The requested URL was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
------------

The logs in the control panel don't show any errors.
Can anyone tell me how to check logs on the CentOS server/MySQL, that might show what happened?

The host says there are no signs of DDoS attacks or anything else.
And I was able to SSH in just fine during the outage.

1608052158080.png
 

CZ Eddie

Active member
Looks like that is the http (not secure) so you should enable this in acp "Enable board URL canonicalization."
Nope, it's an https board. I imagine it goes non-secure when it no longer exists/gets broken.
And that option is already enabled, I just double-checked.
 
Last edited:

Brogan

XenForo moderator
Staff member
A 404 is a fundamental webserver error - something happened at the server level to prevent the domain/page being served.

Check the server error log.
If you aren't sure where that is, your host should know.
 

CZ Eddie

Active member
Got a response on the ticket I created with my host:

----------------
After looking into this for you, I'm not seeing anything on our end that would indicate this is related to your Linode's host or a DDoS attack.

When I first tried pulling up <removed>.org in my browser, all I saw was a blank page but not an error page indicating it was unreachable. I checked the networking tab and saw that it was returning a 304 Not Modified response. Not long afterwards, I attempted to run a curl to test again and received a 200 OK response. I was able to pull up your website in my browser now as well.

While system administration is a bit outside the scope of our support, I wanted to try and provide some resources that might be able to help should this happen again. I noticed from your Linode's console that you were running OpenLiteSpeed and cam across this post from their documentation that should be useful if you run into this again.

Please let us know if there's anything else we can help you with. We're here for you 24/7.
----------------
 
Top