XF 1.5 Starting in June 2017, PayPal will require all requests to use TLS 1.2

Fattycakez1

Active member
Starting in June 2017, PayPal will require all requests to use TLS 1.2 and your PHP configuration does not have the required SSL libraries to support this. Without TLS 1.2 support, user upgrades will not be processed correctly after this date. Please contact your host or system administrator for guidance.

For some reason after 10 months of running my forum this showed up

Is there's any issue with my hosting? also is there's a way to hide it?
 

Fattycakez1

Active member
@Kirby this looks like a new issue.

The message has always displayed for servers which did not have TLS support, but now it seems it may also be showing for those which do.

Most likely due to the URL we use to check being dead: https://tlstest.paypal.com/

Great so it's not from my hosting good,

Will this URL go back up or u guys gonna push an update for a new url or something?

btw my upgrades still working but i'm afraid it won't be as good as before or it will output errors.
 

Brogan

XenForo moderator
Staff member
XF1 is EOL so there won't be a release but clearly there are going to be lots of confused XF1 members posting about this, so we're discussing how best to handle it.
 

Chris D

XenForo developer
Staff member
You can upload the attached file and replace the existing file in the following location:
Code:
library/XenForo/UserUpgradeProcessor/PayPal.php
Naturally, XenForo 1.5 is no longer supported so ultimately the recommendation is to update to XenForo 2.1 at the earliest opportunity.
 

Attachments

  • PayPal.php
    13.2 KB · Views: 37

Fattycakez1

Active member
You can upload the attached file and replace the existing file in the following location:
Code:
library/XenForo/UserUpgradeProcessor/PayPal.php
Naturally, XenForo 1.5 is no longer supported so ultimately the recommendation is to update to XenForo 2.1 at the earliest opportunity.
Worked, Thank you guys.
 
Top