Not a bug Spoiler button still shows when js disabled

Liam W

Well-known member
A non-js fallback has been implemented (it's ugly, but will do ;)), but the button still shows, and clicking it takes you to an invalid link.


EDIT: Only seems to happen on Chrome when going from js enabled to force disabled. Browser issue label probably?


XenForo developer
Staff member
I can't even reproduce this in Chrome (disabling JS via the dev tools).

We have implemented the standard method (JsOnly). If JS gets disabled and <noscript> is handled badly (and I have seen this before when forcing JS off via an extension), there's not much we can do.

Liam W

Well-known member

I used the page options (click the page icon in the address bar) to set Javascript to always block, then hit F5. The QR editor also broke, so I'm pretty certain it's a bug within Chrome rather than anything else.