• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Speed up your XenForo site

rafass

Well-known member
#61
I'm still digging into this. It looks like during the rebuild process, apache downgraded from 2.4.17 (contains the needed code) to 2.4.16. This was announced by cpanel on 10/26 for the edge build, and on 10/27. The current version of easyapache builds the httpd 2.4.16 version. Here was their announcement to the edge users list:

=================================
Apache was upgraded to 2.4.17 in EasyApache build 3.32.3, which was released a couple of weeks ago on Oct 15th. After release, we observed issues caused by REDIRECT_URL being changed to server a full URL, rather than a relative URL / file path.

While some applications have started making changes to ensure their applications and plugins work with the changes, we feel that it’s better to revert Apache back to 2.4.16, and then re-release 2.4.17 after upstream fixes are in place. As such, we will be releasing EasyApache 3.32.4 tomorrow, Oct 26 with the aforementioned changes.

We recommend downgrading to Apache 2.4.16 if you are running into problems with REDIRECT_URL and mod_rewrite. Also, while cPanel doesn’t officially support http2 yet, we know some customers have been tinkering with it. If you downgrade Apache back to 2.4.16, this will remove the http2 and associated modules from the Apache stack.

Once Apache releases a fix for the major issues, Apache 2.4.17 will be patched and then released again.
=================================

It looks like easyapache is still in the 2.4.16 version, cPanel intends to release 2.4.17 as soon as possible after identifying and correcting the issue. The settings I added should pick up the build at that time as soon as it's available, as set in this file:

# cat /var/cpanel/easy/apache/rawopts/Apache2_4
--enable-http2
--with-nghttp2=/usr/local

However, it won't be possible to set that up today..:coffee:
f5.gif
 

eva2000

Well-known member
#63
Always room for improvement re-enabled my KeyCDN account as they have HTTP/2 suppot now :)

Since GTmetrix Chrome 36 doesn't support HTTP/2, using webpagetest.org Dulles vs San Francisco Cable 5Mbp tests to compare. Looking good :D

Forums hosted on 4GB Linode VPS Freemont, California so San Francisco test is naturally faster :)

3 runs per test filmstrip and WPT results - perceived visual render time is all that matters to me :D

dulles-vs-sf-wpt-cable-091115-filmstrip-00.png

dulles-vs-sf-wpt-cable-091115-00.png

dulles-vs-sf-wpt-cable-091115-01.png
 

Amin Sabet

Well-known member
#68
yeah i notice it from chrome dev tools the dom content loaded time for me in Australia dropped from ~2.25s to ~1.35s :)
eva, which [bd] Cache functions do you use? Do you cache pages for guests?

Also, do you mind sharing your KeyCDN advanced settings?
 
Last edited:

Amin Sabet

Well-known member
#74
looking very good :D

oh noticed FIO speeds... best to use Cable 5mbps and 3g mobile fast for compares :D
I had to disable pagespeed defer_javascript because deferring jquery and xenforo.js seemed to be causing problems on my site.

I noticed you are still deferring those. Any members reporting issues with quick reply or smilies?

I'm still not doing too bad. This is from San Francisco, my server being relatively far away on the east coast:

Screen Shot 2015-11-10 at 8.23.35 AM.png
 

eva2000

Well-known member
#76
I noticed you are still deferring those. Any members reporting issues with quick reply or smilies?
check more carefully - i don't defer those ;)

I'm still not doing too bad. This is from San Francisco, my server being relatively far away on the east coast:
looks good and close to what my server sees if i test on other side in Dulles for my Fremont, California server :)
 

Amin Sabet

Well-known member
#77
check more carefully - i don't defer those ;)
I know you have this in your pagespeed.conf:

Code:
pagespeed Disallow */js/jquery/jquery-1.11.0.min.js*;
pagespeed Disallow */js/xenforo/xenforo.js*;
But I don't think that works to exclude them from defer_javascript.

I asked about it with the mod_pagespeed folks here: https://groups.google.com/forum/#!topic/mod-pagespeed-discuss/wBnzNnPMKpM

They asked me to report it as a bug/suggestion here: https://github.com/pagespeed/mod_pagespeed/issues/1173

Looking at the waterfall from webpagetest.org, they appear to be deferred on your site:

waterfall.png