1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Sometimes problem with mails

Discussion in 'Troubleshooting and Problems' started by DRaver, Mar 14, 2014.

  1. DRaver

    DRaver Active Member

    Sometimes the forum is not sending emails.
    Sometimes there is also a bug report.

    Zend_Mail_Protocol_Exception: mail.my-domain.net has timed out - library/Zend/Mail/Protocol/Abstract.php:377
    Erstellt von: Unbekanntes Benutzerkonto, Heute um 15:35 Uhr
    #0 /var/www/my-domain/library/Zend/Mail/Protocol/Abstract.php(415): Zend_Mail_Protocol_Abstract->_receive(120)
    #1 /var/www/my-domain/library/Zend/Mail/Protocol/Smtp.php(313): Zend_Mail_Protocol_Abstract->_expect(354, 120)
    #2 /var/www/my-domain/library/Zend/Mail/Transport/Smtp.php(215): Zend_Mail_Protocol_Smtp->data('Subject: Einfac...')
    #3 /var/www/my-domain/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
    #4 /var/www/my-domain/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #5 /var/www/my-domain/library/XenForo/Model/MailQueue.php(62): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
    #6 /var/www/my-domain/library/XenForo/Deferred/MailQueue.php(10): XenForo_Model_MailQueue->runMailQueue(9.9999990463257)
    #7 /var/www/my-domain/library/XenForo/Model/Deferred.php(252): XenForo_Deferred_MailQueue->execute(Array, Array, 9.9999990463257, '')
    #8 /var/www/my-domain/library/XenForo/Model/Deferred.php(378): XenForo_Model_Deferred->runDeferred(Array, 9.9999990463257, '', false)
    #9 /var/www/my-domain/library/XenForo/Model/Deferred.php(331): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #10 /var/www/my-domain/deferred.php(23): XenForo_Model_Deferred->run(false)
    #11 {main}
    array(3) {
      ["url"] => string(33) "http://www.my-domain.net/deferred.php"
      ["_GET"] => array(0) {
      ["_POST"] => array(4) {
        ["_xfRequestUri"] => string(63) "/conversations/einfach-nur-mal-guten-abend-sagen.103839/page-24"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfToken"] => string(8) "********"
        ["_xfResponseType"] => string(4) "json"
    What is the problem?
  2. Mike

    Mike XenForo Developer Staff Member

    This is saying that your SMTP server connection timed out. That would indicate a connectivity issue between your server and your SMTP server or issues on your SMTP server.

    This is one of the reasons why we generally recommend the built-in PHP mail options unless you have particular reasons to use a separate SMTP server. (And issues like this may have to be tolerated.)
  3. DRaver

    DRaver Active Member

    Error should never be tolerated. I used the procedure since many yreas with my Vbulletin boards and there daily 1000 mails be sent without errors.
  4. DRaver

    DRaver Active Member

    Hey @Mike I once more checked my logs, and whenever this email error comes, the following error is in my log of my Nginx.

    ...."POST /deferred.php HTTP/1.1" 499 0 "http://www.mydomain.net/bla-forum/blabla-forum.76/" "Mozilla/5.0 .......
    Last edited: Mar 19, 2014
  5. Slind

    Slind Active Member

  6. Tracy Perry

    Tracy Perry Well-Known Member

    http://forum.nginx.org/read.php?2,213789,213794#msg-213794 has some information on the 499 status code.... it's not a recognized code but is an nginx one. Basically means the client closed the connection.
    A lot of people that have this error are running on AWS. Do you happen to be by chance?
    Last edited: Apr 8, 2014
  7. Slind

    Slind Active Member

    mhh I run apache.

Share This Page