XF 2.1 Sitemap not creating split pages

Chris D

XenForo developer
Staff member
It doesn’t look like those requests are hitting XF because that looks like a non-standard error page.

Those URLs don’t physically exist on the server but as long as they reach XenForo we intercept them and return the relevant data.

You may need to enable friendly URLs and (if needed) implement the default .htaccess file. This should make those URLs accessible.
 

Mike

XenForo developer
Staff member
Just as a follow up, due to changes in Google's approach, we have no option but to use that style URL for split sitemaps, regardless of whether friendly URLs are enabled within XF. They did use a different approach for a long time without issue and then it stopped working one day, so we had to change it.
 

rickhz

Active member
Chris we have been having issues with redirects and I'm pretty sure the guy who works on the server has had to change the .htaccess file.

Assuming this is the correct .htaccess file do you see issue with this:

# Mod_security can interfere with uploading of content such as attachments. If you
# cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
# SecFilterEngine Off
# SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
RewriteEngine On

# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
#RewriteBase /xenforo

# This line may be needed to workaround HTTP Basic auth issues when using PHP as a CGI.
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
</IfModule>
 

Chris D

XenForo developer
Staff member
You may need to change this line:
Code:
#RewriteBase /xenforo
To:
Code:
RewriteBase /forums
After turning on "Full friendly URLs" in Options > Basic board information if you're facing problems.
 
Top