1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sign-Up confirmation e-mail lands in Spam-folder at Gmail.com

Discussion in 'Troubleshooting and Problems' started by erich37, Oct 9, 2010.

  1. erich37

    erich37 Well-Known Member

    when somebody registers at my website by using a Gmail.com e-mail-address, the confirmation e-mail lands in the Spam-folder of that person at Gmail.com and also contains a warning message from Gmail.

    Gmail-message within the e-mail:
    "Warning: This message may not be from whom it claims to be. Beware of following any links in it or of providing the sender with any personal information....."

    What to do so that the mail does not land in the Spam-folder ?

    Many thanks,
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Unfortunately there isn't much you can do to other than to tell your users to check their spam folder. If there was an easy way to defeat the spam filter then it wouldn't be very useful.
  3. Brentnauer

    Brentnauer Well-Known Member

    Emails sent from my site to GMail work just fine...
  4. bambua

    bambua Well-Known Member

    You can avoid that if you have it send through the actual mail server that hosts the address that the forum sends email as. Rather than just having php send the mail. I've run into that problem with my IT clients before.
    CurveGotti and Jake Bunce like this.
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Ah that makes sense. That would explain the specific gmail message he got.
  6. Blandt

    Blandt Well-Known Member

    Spam filters compare the RDNS with the domain name ... so let say your RDNS is blabla.myhost.com and the domain account sending the email is mydomain.com ----> mydomain.com <> myhost.com
    flagged as spam immediately.
    The way to go about it is as mentioned above.
    Puntocom likes this.
  7. erich37

    erich37 Well-Known Member

    Many thanks for your feedback bambua !
    I am not that experienced of how to do what you are suggesting. Could you please tell me in a few easy steps of how to do this ?

    Thanks again !
  8. Puntocom

    Puntocom Well-Known Member

  9. Blandt

    Blandt Well-Known Member

    What OS / Server are you running?
  10. erich37

    erich37 Well-Known Member

    I do have my own dedicated server running Linux.

    I also have set-up the email-address:

    e-mail: dating@mydomain.com

    and also have entered this e-mail-address into the ACP-section of my XenForo-software.
  11. Blandt

    Blandt Well-Known Member

    Which distro?
  12. erich37

    erich37 Well-Known Member

    distro ? no idea.

    I just came to think:
    within the XenForo-ACP, there is a section called "Email Transport Method" which shows a radio-button for a SMTP setting.

    Do I need to make some settings there and activate SMTP there somehow ?

    I currently have set this to "Default".
  13. Blandt

    Blandt Well-Known Member

    You need to install an SMTP server and configure it properly (free) or buy an smtp account from another provider
  14. erich37

    erich37 Well-Known Member

    I actually do have a SMTP-server named:


    Do I need to enter this address "smtp.mydomain.com" into the XenForo-ACP under "Email Transport Method" ?

    Many thanks for your help !
  15. Puntocom

    Puntocom Well-Known Member

    In my site it worked with Default (shared hosting)
  16. Blandt

    Blandt Well-Known Member

    No problem .
    but where is your smtp.domain.com pointing to ?
    is it pointing to your server? or your domain provider? a third party ?! I know it's confusing but ... :D
  17. erich37

    erich37 Well-Known Member

    the smtp.mydomain.com is actually pointing to my own server.

    So I guess I need to put the smtp.mydomain.com into the "Email Transport Method" of the ACP of XenForo ?
    Including the "Port"-number.
  18. Blandt

    Blandt Well-Known Member

    Yes you do ..
    and make sure to call your host to fix your RDNS to .. hmm say mail.yourdomain.com ;)

    They should configure it instantly
    erich37 likes this.
  19. erich37

    erich37 Well-Known Member

    I just made the SMTP settings in ACP, but still the mail containing the confirmation-link lands in the Spam-folder of Gmail.com :(

    what is the RDNS ? I do not understand......
  20. Shamil

    Shamil Well-Known Member

    RDNS = reverse DNS. What SMTP details are you using, i.e what is the host?
    I could go further and ask for a copy of the original message of the email (click on "More options" -> "Show original" )

Share This Page