XF 2.2 Setting Up a Private Forum group Permission

DigNap15

Active member
Hello
I am having trouble setting up a new Forum Node that is Private and viewable and postable to only one Group (plus Admin of course)
I have done this once before, but I cannot do it now. It is not very easy or intuitve

I have set up a new Forum Node
And a New user Group

The manual says
1. Select The "Private Node" Opton
2 Allow the "View Node" permission for the desired user Groups (s)

But where exactly do I go to make the fourm Private, but open to the Group
 

DigNap15

Active member
Thanks for that Brogan
I saw that, I have tried about ten times
it is not very inutuitve
(I have done it once before for another Group, but I cannot repeat it)

Where is the "Pirvate Node" option
and how do I allow the "View Node" permission

Are there any screen shots?
Or shall I post one from my forum?
 

DigNap15

Active member
I finally did it after 1 hour!
I think the key thing is that you have to Save the View Node Permission, and then click Save again on the Groups list, then you will see the system rebuilding the permissions!
i think the instructions need to be updated to reflect this.
Thanks again Brogan
 

DigNap15

Active member
My second private forum is now up and running.
In a few weeks I will want to make one or both of them visible on the forum.
So that all members will be able to see them, and even look at the threads, but not be able to psot.
They will need to be invited to join the Groups.

I hope I will be able to set this up easily
 

Brogan

XenForo moderator
Staff member
In that case don't have them set as private nodes.

Just revoke the post permission for the Registered user group and allow it for the groups/members you want to be able to post.
 

GW2

New member
I am having a similar problem.
I have a node named "Let's Talk" which I have saved as Private.
See screen shot
1610303120349.png
I have an user group named "Let's Talk Members" that I want to give access to this node. However when I attempt to change the "Let's Talk Members" group general permissions to YES,

1610303685782.png
I receive this message :
1610303838013.png
What am I doing wrong?
 

DigNap15

Active member
In that case don't have them set as private nodes.

Just revoke the post permission for the Registered user group and allow it for the groups/members you want to be able to post.
Hi Brogan
I did it your way and it works really well
But I still find setting Groups and Forum(thread) permissions very problematic, its a very confusing area, and you have to be very precise and see the message "Rebuilding User Permissions" or nothing works
 

GW2

New member
Thanks Brogan,
Here is what the console returns. I have Xenforo set up in a subdomain for testing purposes before going live (migrating from phpbb). I wonder if that is causing this problem?


1610307130886.png
 

GW2

New member
Brogan,
Thank you for your help. We got the 406 Error fixed. You are correct , the problem was mod_sec related. It took a few tries, but our host finally got it fixed.

I know nothing about Apache mod_security, but I thought it might be helpful to others to post the fix that our host implemented:

"We have now whitelisted one rule ie 950906 that was causing an issue. Please check and confirm it from your end. We also checked and could see that there is no other mod_security hit other than 950906 and 950904. If the problem still persists then please provide us the logs from the Xenforo support to check where exactly mod_security is causing conflict so that we can assist you further."
 
Top