Fixed 'Search in forums' and 'Search in categories' in advanced search do not have accessible names

Affected version
v2.2.4

36degrees

Member
The labels for the 'Search in forums' and 'Search in categories' selects in advanced search are not associated with the selects.

This means that these selects do not have an accessible name.
 

Mike

XenForo developer
Staff member
I made reference to this in my reply about radio and checkbox rows, but this is actually an issue that's more general than the specific instance noted. It's actually the same issue as the custom field label association bug report but I'm leaving them separate as the custom field one is a much more complex version of the basic issue.

Essentially this comes up where we've manually built complex form rows. Basic rows will have the necessary associations done automatically. If we needed something that didn't fit one of those (which is caused by the related checkbox here), then we will need to handle these associations manually. I've identified a wide variety of examples that could be improved, though the process may vary for each. Some may need manual label association while others will need role=group + aria-labelledby along with extra aria-label entries.
 

XF Bug Bot

XenForo bug fixer bot
Staff member
Thank you for reporting this issue, it has now been resolved. We are aiming to include any changes that have been made in a future XF release (2.2.5).

Change log:
Ensure that inputs are associated with their labels whenever possible to improve accessibility of certain forms.
There may be a delay before changes are rolled out to the XenForo Community.
 
Top