• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Screen flicker on scroll

tommydamic68

Well-known member
#1
Could this be a javascript conflict of sorts? It happens when I scroll down, it's like a flash. What is strange is I can't recreate it on my macbook, it does happen on my iMac desktop in Safari but not on Chrome, and I wouldn't even bring it up here but its only on my site, not Facebook, Google, MSN etc. Any ideas?

 

Chris D

XenForo developer
Staff member
#4
It's going to be quite difficult to debug.

The only thing I can suggest is to disable each one of the elements on that page that aren't standard, e.g. the user albums block, the advertising, any add-ons etc.

Disable them one at a time, check to see if the flicker goes. If it does, then you have identified the issue.
 

tommydamic68

Well-known member
#5
It's going to be quite difficult to debug.

The only thing I can suggest is to disable each one of the elements on that page that aren't standard, e.g. the user albums block, the advertising, any add-ons etc.

Disable them one at a time, check to see if the flicker goes. If it does, then you have identified the issue.
I stared to disable a few, what's strange is it's only on Safari on my desktop. Not Safari on my laptop or even Chrome on the same computer.
 

Chris D

XenForo developer
Staff member
#6
It's not that strange. Every browser is different even the same browser on different platforms. The platform is sort of irrelevant. Something is likely to be causing it so isolate the cause and go from there.
 

tommydamic68

Well-known member
#7
On a side note- I did notice a similar flicker when clicking the login/ signup button in the past. As the screen changes with that opaque look it would flicker.
 

tommydamic68

Well-known member
#8
It's going to be quite difficult to debug.

The only thing I can suggest is to disable each one of the elements on that page that aren't standard, e.g. the user albums block, the advertising, any add-ons etc.

Disable them one at a time, check to see if the flicker goes. If it does, then you have identified the issue.
Will disabling the add on be sufficient for testing?
 

MagnusB

Well-known member
#10
Try disabling the "Back to top" feature. It is the only one triggering on scrolling as far as I can see. Things like this is usually triggered when the browser are struggling keeping up with the website, usually the js or flash or similar.
 

MattW

Well-known member
#12
and as I've just replied in that thread, you have made several changes to it yourself. I can't reproduce it in Safari on a MAC.
 

MagnusB

Well-known member
#13
As I said, it is probably the browser struggling to keep up, this is usually caused by lots of js and flash on the page or a weaker computer. I see similar behaviour on slow computers when browsing ad heavy sites, combined with lots of js. It doesn't necessarily mean the back to top modification is poor, it just means you need to look at what causes your browser to lag. It can be the combination of many things, it is just the action on every scroll that is triggering it.

For example, if you have ads, try using an ad blocker and see if it improves the performance. Also, try scrolling normally, slowly back and up and see if you can reproduce it that way. To me it only looks like it triggers when you are scrolling fast up and down.