1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Redirect Issue on IIS

Discussion in 'Installation, Upgrade, and Import Support' started by MattGarner, Apr 6, 2013.

  1. MattGarner

    MattGarner Member

    Hey everyone,

    I am trying to install xenForo for the first time. I am doing this on Windows Server 2012 with IIS8 but I'm coming across an issue that goes on about redirect loops. For example:

    Unfortunately the fix for it was a hotfix for IIS 7.0 and I assume it should have been fixed in the newer versions? Does anyone have any solutions so I can get this installed.


  2. ENF

    ENF Well-Known Member


    We have mostly only Windows servers but we're still running 2008 R2 with IIS 7.5 -- we didn't run into this issue at all, that I can remember. So I would assume it's just a configuration issue in your case.

    A few things off top of my head:

    1) Make sure HTTP redirect is not enabled.
    2) Check your bindings for the domain
    3) You may want to try deleting the virtual directory from the IIS manager and recreating it with a fresh mapping.
    4) Try a different browser, just in case.

    Does IIS 8.0 still use the web.config file? Check it for any rouge entries.
  3. ENF

    ENF Well-Known Member

    One other thing... just in case, disable or remove the URL Rewrite settings for XF if you already had them setup. (a just in case measure... I *did* run into an issue with this at one point)
  4. MattGarner

    MattGarner Member

    1. Isn't enabled
    2. Just checked the bindings
    3. Just tried that and the error still happens
    4. Doesn't matter on the browser

    I believe IIS 8 still uses the web.config file but using something called helicon manager to deal with the htaccess files.

    I assume that's something done when you've installed it?
  5. ENF

    ENF Well-Known Member

    Hmm... I stopped using Helicon with IIS 7.5. (had it for IIS 6.0)

    IIS 8.0 should have the same URL Rewriting module (0r more improved) that IIS 7.5 had available.

    You can use this page to set your URL rewrite: http://xenforo.com/help/friendly-urls/ (refer to IIS section)

    If you remove Helicon, any difference?

    For IIS 7.5, I added the URL Rewrite Module to IIS and used the link above to set the rewrite rules (same as what's in the .htaccess). << I did this after the base install was done.

    I'm not sure what else there is... that would cause your issue.
  6. nrep

    nrep Well-Known Member

    I've just upgraded to Windows 2012 and have this same problem in IIS 8.5 - did you find a fix for it?
  7. Mike

    Mike XenForo Developer Staff Member

    @nrep, this particular issue may not be what you're seeing. When it's an install redirect, that can often indicate the files haven't been uploaded correctly or the wrong URL is being used. If it's after an install, it may be something else; it can be hard to be certain as the loop can be caused by bad custom redirects. Otherwise, it might imply that data isn't being passed along to XF correctly.
  8. nrep

    nrep Well-Known Member

    Thanks, I was barking up the wrong tree with this question it seems, as this occurred when the server was first provisioned. It turns out I had to enable ASP.NET 4.5 extensions on the application pool, otherwise the rewrite rules wouldn't work properly. Not entirely sure why, but the rewrites work fine now.
    Last edited: Nov 7, 2014
    Mike likes this.

Share This Page