1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Phpmyadmin Importing Database problem

Discussion in 'Troubleshooting and Problems' started by Brett Peters, Aug 7, 2011.

  1. Brett Peters

    Brett Peters Well-Known Member

    Recently I was trying to install a test install on my server but when I try to upload the database I get the following error, If anyone is good with this sort of thing it may save me some time.

    The only noteworthy thing that I can think of is that my host has updated phpmyadmin.

    error.png
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It looks as if there's an erroneous entry in your .sql backup file for the xf_ip table.

    Are you able to open the backup in a text editor (e.g. Notepad++) and check that particular table, specially the line beginning 2897?
     
  3. borbole

    borbole Well-Known Member

    Can you tell us how big is the size of your backup file?
     
  4. Brett Peters

    Brett Peters Well-Known Member

    Just having a look at the particular table, To me it looks like that when I deleted some XF generated pages that the nodes children references did not get deleted...... Could this be correct ? (I hope not)
     
  5. Brett Peters

    Brett Peters Well-Known Member

    Only small, well under the upload limit if that is what you were referring to
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    It's just a table which logs IP address against content type, so that shouldn't really have any relevance.

    Can you post the line it errors on?
     
  7. Brett Peters

    Brett Peters Well-Known Member

    (2896, 136, 'post', 1872, 'insert', 983916523, 1302653487);
    INSERT INTO `xf_ip` (`ip_id`, `user_id`, `content_type`, `content_id`, `action`, `ip`, `log_date`) VALUES
    (2897, 136, 'post', 1873, 'insert', 983916523, 1302653793),
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Hmm, that all looks fine.

    Just to double check, 2896 is the last entry in the xf_ip table at the moment?
     
  9. Brett Peters

    Brett Peters Well-Known Member

    Thanks for the help Brogan, All fixed now

    Just took a few attempts at uploading :mad:
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    Are you on a shared host?

    It's possible there were server related issues during the import, but other than that I can't suggest why it would suddenly work after failing a few times.
     
  11. Brett Peters

    Brett Peters Well-Known Member

    Yep shared host
     

Share This Page