1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

phpMyAdmin help

Discussion in 'Server Configuration and Hosting' started by screechout, Jun 15, 2015.

  1. screechout

    screechout Member

    Whilst this isn't exactly related to xenforo I was wondering if anyone could help, I had to reinstall xenforo due to messing some stuff up and in the process I'm not sure what I did but I completely messed up phpmyadmin ins the process as well. It prompts me with a login page, I put in the pass word that it says in my config.inc.php but then I am prompted with 1045# Cannot log in to my SQL Server.

    This is what my config.inc.php says

    * Generated configuration file
    * Generated by: phpMyAdmin 4.1.14 setup script
    * Date: Mon, 15 Jun 2015 13:02:08 +0200

    /* Servers configuration */
    $i = 0;

    /* Server: localhost [1] */
    $cfg['Servers'][$i]['verbose'] = '';
    $cfg['Servers'][$i]['host'] = 'localhost';
    $cfg['Servers'][$i]['port'] = '';
    $cfg['Servers'][$i]['socket'] = '';
    $cfg['Servers'][$i]['connect_type'] = 'tcp';
    $cfg['Servers'][$i]['extension'] = 'mysqli';
    $cfg['Servers'][$i]['auth_type'] = 'cookie';
    $cfg['Servers'][$i]['user'] = 'user';
    $cfg['Servers'][$i]['password'] = 'jade';

    /* End of servers configuration */

    $cfg['blowfish_secret'] = '557eafd496aa37.98980975';
    $cfg['DefaultLang'] = 'en';
    $cfg['ServerDefault'] = 1;
    $cfg['UploadDir'] = '';
    $cfg['SaveDir'] = '';

    The above username or password does not work. If anyone can help I would be so grateful! thanks :)
  2. whynot

    whynot Well-Known Member

    Perhaps there is more than one user on the account?
    $cfg['Servers'][$i]['user'] = 'screechout_user';
    $cfg['Servers'][$i]['password'] = 'password';
    screechout likes this.
  3. screechout

    screechout Member

    Thanks for the reply! I've fixed it but uninstalling and reinstalling luckily I didn't need to keep any data!

    But I have another small problem which was my initial problem to begin with Access denied for user 'root'@'localhost' (using password: NO) I get this error when setting up Xenforo, would you be able to help with this? thanks!
  4. BoostN

    BoostN Active Member

    That error is telling you the Username/Password is incorrect or permissions are not correctly setup for the user on the database.

    If your using phpmyadmin, just go to User--> Add Users, fill out the information. Check the Create Database and Grant Privileges option.

    screechout likes this.
  5. screechout

    screechout Member

    I am using phpmyadmin, when you say go to users, I do not see a tab for that. I'm very new to everything so I'm not sure where to find this, would this be in the database?
  6. screechout

    screechout Member

    Sorry I did not look properly! editing now!
  7. BoostN

    BoostN Active Member

    After creating the new user, use the Username and new Database name for your XenForo installation.
  8. screechout

    screechout Member

    It is still coming up with that error. With the information that I need to fill, do I have to have a password or can I select no password
  9. BoostN

    BoostN Active Member

    I would assume a password is required.
  10. screechout

    screechout Member


    This is what I was originally trying to set it up like,

    Then on Xenforo: MySQL Username: root
    MySQL Database Name: Forums

    The same with the method that you said above, I'm sure I'm doing something incorrect here :/
  11. BoostN

    BoostN Active Member

    It *looks* right from here, but I'm not sure why you're not able to set it up.
  12. screechout

    screechout Member

    I'm not quite sure what else to do, when I first installed Xenforo I had this error, then it worked so not sure what happened to get it to work the first time around
  13. BoostN

    BoostN Active Member

    I'm using XAMPP, but I did I have it happen to me. I resorted to the method above (create user, then db) and I was able to set everything up.
  14. screechout

    screechout Member

    I'm using Wamp, not sure how I got it to fix the first time. This is what it looks like when I go onto the users tab. Not sure if this means anything, but just in case

  15. Tracy Perry

    Tracy Perry Well-Known Member

    Hopefully you aren't using root in a production environment for your mysql account. Very foolish move if you are.
  16. BoostN

    BoostN Active Member

    This was on his local PC...

Share This Page