1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Pasting with the mouse into the admin search doesn't fire the search action

Discussion in 'Resolved Bug Reports' started by rellect, Aug 13, 2014.

  1. rellect

    rellect Well-Known Member

    Just a little thing that caught me few times.
    When a string is pasted into the input by the mouse (right click -> Paste), it doesn't fire the search action.
     
  2. SamL

    SamL Active Member

    Pasting is not supposed to explicitly execute the function. It's just a text entry field like any other.
    For instance, what if you wanted to paste that text into the field and edit it before searching for the edited term....
     
  3. rellect

    rellect Well-Known Member

    It does work with ctrl+v, so...
     
  4. Karelke

    Karelke Active Member

    I presume the script does not recognize a paste command, CTRL + V simply triggers a keydown/keyup event.

    I believe the browser does not fire an event after pasting text with the mouse, therefore it's nearly impossible to trigger the search action.
     
  5. rellect

    rellect Well-Known Member

    There's a 'paste' event. I verified that now again just to be sure.
     
  6. Karelke

    Karelke Active Member

    There seems to be a small problem:

    http://stackoverflow.com/questions/7160073/in-jquery-how-to-handle-paste
     
    Last edited: Aug 13, 2014
  7. Mike

    Mike XenForo Developer Staff Member

    I've fixed this in a couple places, though there are likely a few places which haven't been changed (though they've very unlikely to come up).

    We don't need to know what is pasted, just that the paste is happening. Some browsers do give you access to the clipboard data once the paste is happening as well.
     

Share This Page