1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Page Width Controller Margin produces a Server Error

Discussion in 'Resolved Bug Reports' started by ijeffers, Oct 10, 2010.

  1. ijeffers

    ijeffers Active Member

    Was playing about with the style properties to try and see what effected what.

    Trying to put or alter a value in either the Top, Left Right or Bottom Margin's and updating will get XenForo to produce and Unexpected Server Error, please try later.

    Happens in both the Default and any New Style.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Same here.

  3. Mike

    Mike XenForo Developer Staff Member

    Please check the server error log in the tools section to see if there's anything there.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Sorry, should have mentioned yesterday Mike, the logs are empty.
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Just to follow up, I have just performed the same steps as I did yesterday and it worked fine.
    It seems to be an intermittent problem.

    I have noticed this server error message when I was doing something else but didn't log it at the time as I was working on another issue.
    I will make sure I do so in future.
  6. ijeffers

    ijeffers Active Member

    Mine's still consistently doing it on two installs, seperate server.

    Checked the Error Log and nothing is being logged.
  7. Mike

    Mike XenForo Developer Staff Member

    Can you turn on debug mode ($config['debug'] = true; in the config.php file) and see what gets reported?

    It's annoying that nothing's in the error log. I'd really like to track that down.
  8. ijeffers

    ijeffers Active Member

    Here you go Mike, this is what I got when trying to set the top padding, the same occurs when trying to change the bottom:

    Server Error

    Undefined index: padding-right
    1. XenForo_Application::handlePhpError()inXenForo/Model/StyleProperty.phpat line908
    2. XenForo_Model_StyleProperty->_getPaddingMarginShortCuts()inXenForo/Model/StyleProperty.phpat line824
    3. XenForo_Model_StyleProperty->compileCssProperty_compileRules()inXenForo/Model/StyleProperty.phpat line706
    4. XenForo_Model_StyleProperty->compileCssPropertyForCache()inXenForo/Model/StyleProperty.phpat line657
    5. XenForo_Model_StyleProperty->updatePropertyCacheInStyle()inXenForo/Model/StyleProperty.phpat line615
    6. XenForo_Model_StyleProperty->rebuildPropertyCacheInStyleAndChildren()inXenForo/Model/StyleProperty.phpat line1200
    7. XenForo_Model_StyleProperty->saveStylePropertiesInStyleFromInput()inXenForo/ControllerAdmin/Style.phpat line346
    8. XenForo_ControllerAdmin_Style->actionStylePropertiesSave()inXenForo/FrontController.phpat line303
    9. XenForo_FrontController->dispatch()inXenForo/FrontController.phpat line132
    10. XenForo_FrontController->run()in/home/ijeffers/beta.fallenhorizon.com/forums/admin.phpat line13
  9. Mike

    Mike XenForo Developer Staff Member

    It's a shame that I couldn't reproduce this, but I do see what's wrong with that line of code, so I think this is fixed now. :)
  10. ijeffers

    ijeffers Active Member

    Great stuff! :D

    Guessing it'll work it's way in to the next beta release? :)

Share This Page