1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Outdated Templates, updated with WebDav are still showing as Outdated Templates

Discussion in 'Resolved Bug Reports' started by Miko, Dec 11, 2010.

  1. Miko

    Miko Well-Known Member

    In Beta 5 Outdated Templates, that have been updated with WebDav are still showing as Outdated Templates.

    I tried rebuilding the master data /install/index.php?upgrade but that didn't help

    Saving the template in Admin CP also does not help, no matter what the templates are showing in the Outdated Templates.

    Couple of Examples:

    category_view > Custom Version: , Master Version: 1.0.0 Alpha 3
    footer > Custom Version: , Master Version: 1.0.0 Beta 5

    Just to be clear I know that I have updated the code correctly in each of the templates that are showing as Outdated, but...

    To be 1000% sure I even copied and pasted the footer template from the B5 Master Style into my custom style and it's still showing as Outdated :(

    Edit 2

    I just noticed that some templates like PAGE_CONTAINER are not showing in the Outdated Templates... which is even more confusing

    Edit 3

    node_list.css are different in the Master style and in my custom style, however I never touched it or edited it. In admin CP is not even showing me the rex X to revert the template.

    I didn't change any colour in the style properties either....

    Left Side is the B5 Master Style


    I fixed the node_list.css by uploading the master version with WebDav and then Reverting it in Admin CP

    Edit 4

    I exported the style xml file and opened it in a code editor and noticed that some of the templates are showing as:

    <template title="footer" addon_id="" version_id="0" version_string="">

    while the one that are actually working correctly by not showing in the Outdated Templates list are showing as:

    <template title="PAGE_CONTAINER" addon_id="XenForo" version_id="1000035" version_string="1.0.0 Beta 5">

    Looks like the templates that are showing in the Outdated list are missing the addon_id="" version_id="0" version_string=""

    Edit 5

    Re importing the style xml didn't do anyting.

    Edit 6

    The only solution that is working is to revert the templates with empty addon_id="" version_id="0" version_string="" and reapply the changes.

    Doing that will work and turn the empty id as follow:

    <template title="footer" addon_id="" version_id="0" version_string="">


    <template title="footer" addon_id="XenForo" version_id="1000035" version_string="1.0.0 Beta 5">

    Now that I covered all angles I leave this one for you Mike as it's definetly a bug :)
  2. Blandt

    Blandt Well-Known Member

    maybe cache issue ? ... restart apache and see if that cures it
  3. Miko

    Miko Well-Known Member

    Just tested restarting apache and mysql, same result.

    The problem was there in B4, but i could have swore that Mike said that he fixed it in B5
  4. Romchik®

    Romchik® Well-Known Member

    I had 5 outdated templates. I should revert all of them and then edit again. Now I have 0 outdated templates. Seems like bug.
  5. Miko

    Miko Well-Known Member

    Reverting and re apply it's the only solution that works.

    I'm sure it will be fixed in the next release :)
  6. Mike

    Mike XenForo Developer Staff Member

    I think I have a fix for this now, though it's not retroactive. It only applies if the first time you edit a template (in the non-master style) is via WebDAV. As a workaround, you should be able to edit the template via the web interface and set the add-on appropriately (probably to "XenForo"). The version should then be maintained in the future.

Share This Page