1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Outdated templates after upgrading: What to do?

Discussion in 'Installation, Upgrade, and Import Support' started by K Ozturk, Jun 21, 2012.

  1. K Ozturk

    K Ozturk Member

    Hi,

    After having upgraded to 1.1.3, the control panel says that attached_files.css is outdated (version still shows 1.1.1). How do I update it without messing things up?

    Thanks.
     
  2. MagnusB

    MagnusB Well-Known Member

    Just revert it, it should update it. Take not of any change you may have done to the file though, as it will be removed when reverting it.
     
    Yorick likes this.
  3. Chris D

    Chris D XenForo Developer Staff Member

    MagnusB is spot on.

    It sounds like you've made changes to the attached_files.css template before. Work out what these changes were, put them into EXTRA.css and then revert the template.

    EXTRA.css is a spare .css template which will never be overwritten by an upgrade. You can put any CSS changes in there that you like and they'll always be applied. You may only very occasionally find that some changes in EXTRA.css don't apply. In cases like this, add !important to the end of your property.

    e.g.

    .message
    {
    color: red!important;
    }

    The !important will be sure to override the default behaviour.
     

Share This Page