1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Browser Issue OS X Safari Text Selection jump in Editor issue

Discussion in 'Resolved Bug Reports' started by tommydamic68, Dec 21, 2015.

  1. tommydamic68

    tommydamic68 Well-Known Member

    I have the latest version of Xenforo 1.5.4, using Safari on a mac, if trying to copy text in a thread with the cursor - the screen "jumps."
     
    ncbetz likes this.
  2. HWS

    HWS Well-Known Member

    Thats Safari specific, has nothing to do with XF. It does that with all HTML editor input fields at all web sites with any software. Just try Chrome and it will work.
     
  3. tommydamic68

    tommydamic68 Well-Known Member

    Just suddenly? Its never done that before, ever, on any site/ forum I visit.
     
  4. arn

    arn Active Member

    I was able to reproduce this on my 12" MacBook and iMac. The report of this issue appeared here: http://forums.macrumors.com/threads/i-cant-post-on-macrumors.1946934/#post-22403760

    How I was able to reproduce it:

    Retina MacBook or iMac
    OS X 10.11.2
    Safari 9.0.2 - No plugins enabled

    Procedure: Go to a thread, scroll to reply box. type in enough text for a scroll bar to appear in the Rich text editor. Tap and drag to start selecting text. The browser page then instantly jumps to the footer. I reproduced this on Xenforo.com

    Here's a video. The jump happens quickly, so it's hard to tell from video alone without the accompanying description:

    http://f.cl.ly/items/2Y0R090f1j1g1A3y0p0R/weird_jump.mov

    I've also had it happen in the EDIT pop-up window, while editing this post. I recently upgraded to 1.5 from 1.4, so it might have been introduced then.

    Edit: After upgrading my iMac to latest OS X, it happens on it too.
     
    Last edited: Dec 27, 2015
  5. arn

    arn Active Member

    Here's it happening in the edit window:
     

    Attached Files:

  6. Nuno

    Nuno Active Member

    I can reproduce this too: iMac with OS X 10.11.2 and Safari 9.0.2
     
    arn likes this.
  7. Chris D

    Chris D XenForo Developer Staff Member

    This was a duplicate report, so I have merged the threads.
     
  8. arn

    arn Active Member

    This isn't true - at least, what's being described here is not typical.

    arn
     
    Last edited: Dec 28, 2015
  9. HWS

    HWS Well-Known Member

    Try it at at vB forum or any other editor window at any other software and you will see the same. No matter if TinyMCE or Redactor. The recent Safari does not work well with them.

    But that should be solved. I do not know if Apple or XenForo has to solve it. XenForo should try it.
     
  10. arn

    arn Active Member

    You're right it does happen on vB as well.

    But it seems Xenforo uses a heavily modified old version redactor, so it falls back on them. I don't think Apple typically provides timely updates on such matters.
     
    Last edited: Dec 28, 2015
  11. HWS

    HWS Well-Known Member

    Not only vB. It happens with every editor input field in every web interface. We experienced it when editing a newsletter in the editor of our newsletter service.

    You have to switch browsers to prevent it. I agree it is very unfortunate. Hopefully Apple will provide an update soon.
     
  12. arn

    arn Active Member

    I tried creating a simple textarea field to simplify it so it would be easier to report to Apple, but I couldn't. I suspect most of those other editors are using Redactor or TinyMCE. You found any examples of simple text fields that it happens in?
     
  13. Chris D

    Chris D XenForo Developer Staff Member

    I have been able to reproduce this issue using a fairly common rich text editor set up involving a contenteditable body inside an iframe. I've also been able to reproduce the error on several popular rich text editors including TinyMCE and CKEditor. As this issue is not exclusive to XenForo it suggests a browser bug.

    I am in the process of creating a simplified reproduction case to send to Apple and I will update this thread if there are any updates on that. In the meantime, however, this is being marked as a browser issue.
     
    Shamatix, arn and HWS like this.
  14. KC Riley

    KC Riley Active Member

    Hi Chris,

    Have you received any response back from Apple on this issue with Safari?
     
    arn likes this.
  15. Chris D

    Chris D XenForo Developer Staff Member

    It was closed by Apple as a duplicate, so from here on out we won't hear anything.
     
  16. arn

    arn Active Member

    well, at least that's promising.

    arn
     
  17. Chris D

    Chris D XenForo Developer Staff Member

    Well, I wouldn't get your hopes up.

    I opened a bug report in November 2014 relating to a specific RTL glitch and that was quickly closed as a duplicate. I think it was iOS 9.2 (way over a year later) that it was actually fixed. The annoying thing about duplicate reports though is you can't see other people's reports, and get no updates on reports you've made after they're closed. Still the same on iOS 9.3 beta... maybe iOS 10...
     
  18. KC Riley

    KC Riley Active Member

    Strange enough Chris, I'm using mobile Safari right now and I haven't run into the issue yet.

    I've only experienced the issue with desktop Safari. I'll probably have to put together a notification for my members to let them know to use Chrome and Firefox on their Macs.
     
  19. Chris D

    Chris D XenForo Developer Staff Member

    Ugh, my brain is somewhere else at the moment, sorry.

    I know this is about OS X Safari but I had iOS in my head for some reason. I managed to trigger something similar with iOS Safari earlier, I wonder if that's a separate bug. I'll need to check that later.
     
  20. ncbetz

    ncbetz Formerly Noah Betz

    I accidentally make a thread on this here (I never found it when searching), but just to let you know, I have this issue also.
     

Share This Page