• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Not getting verification email

hterrag

Active member
#1
I've just migrated to XF from VB and now I tried to create an account and I'm not getting any verification email. What seems to be the problem?
 

Brogan

XenForo moderator
Staff member
#2
Check the mail server logs to ensure mails are being sent.
If you don't know how to do that, ask your host for help.

If mails are being sent, check your spam folder.
 

hterrag

Active member
#3
I ask my host to check they said there are no issues on their end. There are also no mails in the spam/junk folder also.

What is the problem here?
 

Brogan

XenForo moderator
Staff member
#6
In which case you need to check you have email configured correctly and the options related to verification emails set up.
 

hterrag

Active member
#7
The "Email transport method" is set to default and I've enable the email confirmation.

So what seems to be the problem?
 
Last edited:

Tracy Perry

Well-known member
#8
The "Email transport method" is set to default and I've enable the email confirmation.

So what seems to be the problem?
Are you on a shared host, a VPS or a dedicated server?
Since you said it's on the "default" it indicates you are on a VPS or dedicated server (since it uses the PHP mail functions, which depend on an MTA being installed - like Exim, Postfix).
If you are on a shared hosting environment then you need to be using the SMTP function and use the credentials that you have configured in your MTA setup in your panel for the account to send from.

So the problem is, if you aren't on a VPS/dedi then you have the wrong option selected (or at least I'm pretty sure it is - I never got php functions to work when I was with a shared host for the short time I was).
 

Mike

XenForo developer
Staff member
#9
Shared hosts would generally have an MTA installed. Whether they apply some sort of limits or they failed to update PHP's configuration for it may be a different story. (Though PHP points to the standard sendmail position which popular MTAs generally implement.)

If email isn't working with the default options, switching to SMTP is a worthwhile thing to try. The default system you have effectively no ability to change unless you have root access on the server.
 

Tracy Perry

Well-known member
#10
Shared hosts would generally have an MTA installed. Whether they apply some sort of limits or they failed to update PHP's configuration for it may be a different story. (Though PHP points to the standard sendmail position which popular MTAs generally implement.)

If email isn't working with the default options, switching to SMTP is a worthwhile thing to try. The default system you have effectively no ability to change unless you have root access on the server.
Yeah, but for some reason I never could get it to work with HostGator. I ended up having to use the SMTP functions. It had to do with some restrictions that they had in place (according to their tech support).
That was one of the big reasons I left them after about 3 months and got a VPS.
 

hterrag

Active member
#11
Are you on a shared host, a VPS or a dedicated server?
Since you said it's on the "default" it indicates you are on a VPS or dedicated server (since it uses the PHP mail functions, which depend on an MTA being installed - like Exim, Postfix).
If you are on a shared hosting environment then you need to be using the SMTP function and use the credentials that you have configured in your MTA setup in your panel for the account to send from.

So the problem is, if you aren't on a VPS/dedi then you have the wrong option selected (or at least I'm pretty sure it is - I never got php functions to work when I was with a shared host for the short time I was).
Yes I'm on shared hosting. I tried using SMTP with the settings in cpanel for one of an email accounts I created but can't get it to work. I entered the outgoing server name and port 465 and tried with SSL and TSL. Any ideas why?
 

Tracy Perry

Well-known member
#12
Make sure the port is correct... some use (like gmail) 587 for TLS and 465 for SSL.... and TLS usually works on port 587. There should be a guide somewhere by your host to help set up the SMTP settings.
 

hterrag

Active member
#13
Yes I've double checked the port and it is correct, however I still am not receiving the email confirmation.

I haven't tried Gmail's SMTP yet. Is there any difference between the SMTP on my shared host and the one in Gmail? Like performance and limitations?
 

Tracy Perry

Well-known member
#14
Yes I've double checked the port and it is correct, however I still am not receiving the email confirmation.

I haven't tried Gmail's SMTP yet. Is there any difference between the SMTP on my shared host and the one in Gmail? Like performance and limitations?
Limitations of 500 an hour and a few other things. I have several Gmail APP hosted domains that I have used in the past.
If the smtp is not working it's either a port or an authentication issue.
 

hterrag

Active member
#15
Limitations of 500 an hour and a few other things. I have several Gmail APP hosted domains that I have used in the past.
If the smtp is not working it's either a port or an authentication issue.
Well I don't want to have to use Gmail since I have it on the server. I've researched online and someone said;

"I solved it once be sure to check your time stamps on your panel and email on php folders on your roots to gain access ."

How can I check the above?
 

Tracy Perry

Well-known member
#16
The point is you don't have to use Gmail... but you DO have to use the correct settings for your SMTP provider.
Who is your hosting provider?
 

Tracy Perry

Well-known member
#18
Im on Knownsrv shared host. Also none of the emails are being sent out even the password reset.
If it's knownsrv.com then you answer (for smtp) lay here:
Please use the following information for e-mail settings:

Protocal: POP3
Incoming Mail Server: mail.yourdomain.com
Username: email@address.com
Outgoing Mail Server: mail.yourdomain.com
Outgoing Mail Port: 26

Few things to note:
- Replace yourdomain.com with your domain name.
- The username is your full email address, so if you're checking email for mike@knownsrv.com, that would be your email address.
- Some ISPs block port 25, so we offer both 25 and 26
- In order to send outgoing email through our servers, we require authentication while sending. There should be an area to setup authentication for outbound email.
If you have any questions or problems setting up your email, please open up a support ticket and we will help accordingly.
This is direct from their knowledgebase at
https://knownsrv.com/clients/knowle...-I-use-for-my-incomingoroutgoing-servers.html