1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 No Upgrade Available

Discussion in 'Installation, Upgrade, and Import Support' started by mjp, Mar 11, 2014.

  1. mjp

    mjp Well-Known Member

    - I have successfully upgraded three of the four forums I manage to 1.3.
    - Two were upgrades from 1.2.5, one was an upgrade from 1.3 rc2. All three of them are older forums.
    - On the newest install, one that started with 1.3 beta, I get an upgrade error. Not an error message, strictly speaking, but it fails, since going to /install just gives me:

    You are already running the current version (1.3.0 Release Candidate 2). To do a fresh install, click here.

    All four of those installations run on corporate servers, one forum per server, nothing else runs on them. So I know the files are uploading properly, and I am pretty confident that there isn't any caching or host-related issue (since we are the host - and the other three, on identical servers, upgraded without a hitch).

    I have:
    - Downloaded the upgrade package several times, both the upgrade and the full package, and re-uploaded to the server.
    - Deleted the XenForo library (which predictably broke the forum) and re-uploaded it (which predictably brought it back to life).
    - Rebuilt all the caches.
    - Sacrificed a live chicken.

    That's all I can think of to do, but I am still faced with "You are already running the current version (1.3.0 Release Candidate 2).

    So if anyone has any ideas, I'm all ears.

    Though to be completely honest, my ears are quite beautifully proportioned and appealing, so don't take that last bit literally.
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    If you are running some sort of opcode caching mechanism, make sure it restarts or refreshes.
     
  3. mjp

    mjp Well-Known Member

    Negative, Kimosabe.
     
    Last edited: Mar 12, 2014
  4. mjp

    mjp Well-Known Member

    I'm not normally a quitter, but I give up on this.

    I've downloaded and uploaded the package enough times to gain me some sort of idiot's award, but the version stays at 1.3 rc2, so to hell with it. Maybe 1.3.1 will fix it. Maybe it won't, who knows? Since I have no clue what the cause is, I'm in no position to speculate.

    I'll mention that the upload doesn't even disable the forum (triggering the "Inactive Board Message"). I know that sounds as if the files are not uploading, but that is not the case. They are. From my end it looks as if something is wrong with the 1.3 upgrade package for this particular domain, but what do I know.

    Off to open a support ticket I suppose. The last resort of scoundrels and fools!
     
  5. Mike

    Mike XenForo Developer Staff Member

    If the files are uploaded correctly and there's no opcode caching, there must be something else preventing PHP from seeing the new files. Unfortunately, that would likely be something on your server rather than XF related so it will probably be tricky for us to provide much support.
     
  6. Slavik

    Slavik XenForo Moderator Staff Member

    Are you using any web-server caching such as litespeed cache etc?

    Can you try restarting the httpd service.
     
  7. HWS

    HWS Well-Known Member

    Uploaded to the wrong position?
    Used the wrong zip to upload?

    I too made such stupid errors and had situations like you now. :)
     
  8. mjp

    mjp Well-Known Member

    Sorry I didn't follow up right away, but the problem was fixed by an Apache restart. So I'm still not sure of the precise cause, but I suppose when in doubt, reboot! It worked for our forefathers, right? Or something.
     

Share This Page