XF 2.1 No registrations for a month

Chad

Active member
Just realized I have not had new registrations for nearly a month. I tested the registration page, clicking submit just refreshes the page. Weird. Never seen this happen before and I have not even made any changes in quite some time.

Any one know what may cause registration page to refresh on submission?
 

Brogan

XenForo moderator
Staff member
Your site is heavily customised.

Most likely it will be due to the third party style, an add-on, or some other customisation, possibly involving javascript.

Reverting to a default style with all add-ons disabled will rule out third party code issues.
 

Chad

Active member
Thanks Brogan and @AndyB (for private help). I just disabled all social registration/login accounts across the board. I recreated the default XF style and activated user selection. Tried registering again, no go. I disabled all add-ons too, hard refreshed registration page (which shows default XF style) and still just refreshes itself upon registration.

Note, add-ons re-enabled back for now.
 

Brogan

XenForo moderator
Staff member
The browser console will likely point to any issues.

You would need to leave it in a default state in order to be able to check what's happening.
 

Chad

Active member
Just checked console in Firefox:

Code:
Some cookies are misusing the recommended “SameSite“ attribute 2
Cookie “__cfduid” has been rejected because it is in a cross-site context and its “SameSite” is “Lax” or “Strict”. rocket-loader.min.js
Cookie “__cfduid” has been rejected because it is in a cross-site context and its “SameSite” is “Lax” or “Strict”. rocket-loader.min.js
Google Analytics is being shimmed by Firefox. See https://bugzilla.mozilla.org/show_bug.cgi?id=1493602 for details. sandbox eval code:1:9
The resource at “https://www.talkjesus.com/styles/fonts/fa/fa-brands-400.woff2?_v=5.12.1” preloaded with link preload was not used within a few seconds. Make sure all attributes of the preload tag are set correctly. register
 

Chad

Active member
Firefox Console:

Code:
Layout was forced before the page was fully loaded. If stylesheets are not yet loaded this may cause a flash of unstyled content. preamble.min.js:4:73
NaN register:942:12
Google Analytics is being shimmed by Firefox. See https://bugzilla.mozilla.org/show_bug.cgi?id=1493602 for details. sandbox eval code:1:9
Invalid color value provided to Reftagger. Must be in hex format. RefTagger.js:2:1826
The resource at “https://googleads.g.doubleclick.net/pagead/viewthroughconversion/960486446/?random=1621170968036&cv=9&fst=1621170968036&num=1&bg=ffffff&guid=ON&resp=GooglemKTybQhCsO&eid=2505059650&u_h=864&u_w=1536&u_ah=834&u_aw=1536&u_cd=24&u_his=3&u_tz=-240&u_java=false&u_nplug=0&u_nmime=0&gtm=2oa5c1&sendb=1&ig=0&data=event%3Dgtag.config&frm=0&url=https%3A%2F%2Fwww.talkjesus.com%2Fregister%2F&ref=https%3A%2F%2Fwww.talkjesus.com%2F&tiba=Register%20%7C%20Talk%20Jesus&hn=www.google.com&async=1&rfmt=3&fmt=4” was blocked because content blocking is enabled. register
 

MisakiTaro

Active member
Yes. I found the code.

PHP:
if (isset($_SERVER['HTTP_X_FORWARDED_FOR']))
{
$_SERVER['REMOTE_ADDR'] = $_SERVER['HTTP_X_FORWARDED_FOR'];
}

Add this to your config.php file.
 

Chad

Active member
Found the culprit. Memcache apparentely stopped running and the config had this code in there. Once removed, registration worked again. Now, onto fixing memcache.

Code:
// BACKEND CACHING
$config['cache']['backend'] = 'Memcached';
$config['cache']['backendOptions'] = array(
    'compression' => false,
    'servers' => array(
        array(
            // your memcached server IP /address
            'host' => 'localhost',
            // memcached port
            'port' => 11211,
        )
    )
);

// FRONTEND CACHING
$config['cache']['enabled'] = true;
$config['cache']['provider'] = 'Memcached';
$config['cache']['config'] = [
    'server' => '127.0.0.1'
];
$config['cache']['sessions'] = true;
$config['enableAddOnArchiveInstaller'] = true;
 
Top