1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed New users cannot register

Discussion in 'Resolved Bug Reports' started by Luciano, Oct 7, 2010.

  1. Luciano

    Luciano Member

    Everything seems to work fine, I had a problem on installation, could not set temp dir, but i edited the temp dir like shown in an thread here and it worked.
    configuration went fine...

    BUT if a new user wants to register.. he gets a server error when posting registration details.
    i set debug to 1 and got following error messages:
    Its just a test install and I wont be going live before gold, so its not a hurry, but wanted to let you know so there could be a fix in next version

  2. Floris

    Floris Guest

    This seems to go away if you

    a) download the .zip again from the client area
    b) .htaccess close the dir, so users can't enter it
    c) upload the .zip online, unpack it oline, overwrting what was there.
    d) run install/ (not upgrade, but install step)
    e) if goes without errors this time, then try to see if users can register again.
  3. Luciano

    Luciano Member

    thx for the very quick reply !!!
    I will try tonight (at office now)
    Just one question: b) .htaccess close the dir, so users can't enter it
    you mean where i uploaded the zip? and remove the htaccess file and zip file when finished unzipping?
    or add a deny all to the htaccess in the main xenforo dir?
  4. Mike

    Mike XenForo Developer Staff Member

    That's a very different error Floris. I don't think a reinstall would fix that.
  5. Luciano

    Luciano Member

    Just did as floris said...
    but still exactly the same error...
    I then deleted all and did a second new install..
    got the error


    An error occurred. Please click the button below for more information.
    (without any button ...) but it continued...
    then it stopped giving me only

    without anything else...
    I refreshed the page.. (right mouse click : reload page)
    it continued
    and then went to setup admin...
    everything seems to work ok..
    when I want to register a second user.. i enter all registration details..
    and after i click: Sign up
    it gives me exactly the same error. (the one I posted above)

    PS: The server is slow, but I have vbulletin running on it without problems.. and it said when i installed xenforo that all requirements are met.

    If you want i can post a link to php config.
  6. Decent60

    Decent60 Well-Known Member

    Did you check to make sure that your MySQL was at least 5.0?
    nvm, that's prolly a silly question because I wouldn't think that the forum would run at all if it wasn't.
  7. Luciano

    Luciano Member

    well its mysql 5.0.51a
    Its a free testserver i only use for dev stuff (usually if it works there it works everywhere)
    phpinfo: http://www.babelart.000space.com/info.php
    xenforo: http://www.babelart.000space.com/forum/

    The error has to do with sockets..
    phpinfo shows: Sockets Support enabled

    but you also have in phpinfo:
    disable_function: sexec,system,passthru,shell_exec,escapeshellarg,escapeshellcmd,proc_close,proc_open,ini_alter,dl,popen,popen,pcntl_exec,socket_accept,socket_bind,socket_clear_error,socket_close,socket_connect,socket_create_listen,socket_create_pair,socket_create,socket_get_option,socket_getpeername,socket_getsockname,socket_last_error,socket_listen,socket_read,socket_recv,socket_recvfrom,socket_select,socket_send,socket_sendto,socket_set_block,socket_set_nonblock,socket_set_option,socket_shutdown,socket_strerror,socket_write,stream_socket_client,stream_socket_server,pfsockopen,stream_set_timeout,disk_total_space,disk_free_space,chown,diskfreespace,getrusage,get_current_user,set_time_limit,getmyuid,getmypid,dl,leak,listen,chgrp,link,symlink,dlopen,proc_nice,proc_get_stats,proc_terminate,shell_exec,sh2_exec,posix_getpwuid,posix_getgrgid,posix_kill,ini_restore,mkfifo,dbmopen,dbase_open,filepro,filepro_rowcount,posix_mkfifo,putenv,geoip_open,sleep

  8. Mike

    Mike XenForo Developer Staff Member

    Based on PHP docs, this shouldn't happen. This is possibly a bug in Zend Framework, but I've now worked around it in our code.

    It looks like your server may have issues communicating with outside servers. (On an intranet?)
  9. Luciano

    Luciano Member

    No its a free server at 000space.com Link posted in post above.
  10. Mike

    Mike XenForo Developer Staff Member

    They probably limit your ability to connect out to servers. Otherwise it's basically a spam farm...
  11. Luciano

    Luciano Member

    You are right.. Thanks for the effort.

Share This Page