• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Users cannot register

Brandon Sheley

Well-known member
#4
what exactly do you mean?
http://xenforo.com/help/friendly-urls/

If after uploading XenForo, you do not see an ".htaccess" file in your XenForo root directory, rename htaccess.txt to .htaccess (be sure to include the "." prefix). You should now be able to enable friendly URLs. If, after enabling friendly URLs your XenForo installation does not function correctly, please contact your host to confirm that they have mod_rewrite installed and allow overrides via an .htaccess file.
 
#5
ok, I have friendly urls on. and I have the htaccess file. Both of them actually. Now its says the following on the link you provided:

(Do I create a file named web.config??)

To enable friendly URLs in IIS 7, put the following code into a web.config file in your XenForo root directory:
<?xml version="1.0" encoding="UTF-8"?>
<configuration>
<system.webServer>
<rewrite>
<rules>
<rule name="Imported Rule 1" stopProcessing="true">
<match url="^.*$" />
<conditions logicalGrouping="MatchAny">
<add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
<add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
</conditions>
<action type="None" />
</rule>
<rule name="Imported Rule 2" stopProcessing="true">
<match url="^(data|js|styles|install)" />
<action type="None" />
</rule>
<rule name="Imported Rule 3" stopProcessing="true">
<match url="^.*$" />
<action type="Rewrite" url="index.php" />
</rule>
</rules>

</rewrite>
<httpErrors existingResponse="PassThrough" />
</system.webServer>
</configuration>
 
#7
I dont know the details in full. But godaddy is the host. Trust me when I smh.. I didnt make that decision. But im trying to set these up for a friend. Now when I go to log out of the forums, It gives me the 404. ftpshot.JPG logout.JPG I have included to screen shots. One is the ftp. the other is the 404 error code when I attempt to logout