1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 New User gets Blank Page on Registering

Discussion in 'Troubleshooting and Problems' started by kunik1962, Aug 26, 2014.

  1. kunik1962

    kunik1962 Member

    I have been testing user registrations on a new XenForo installation. I went and disabled all the admin User Registration options, leaving just the Moderators manually approve option checked

    The user fills out the registration form hits send then this url loads with a blank page:

    http://xlnation.net/xenforo/register/register

    If you hit refresh you are back at the registration page. The thing is though that the entire process worked fine and the user is now in the "User Awaiting Approval" Is there a template missing? Can anyone offer some help?
     
  2. kunik1962

    kunik1962 Member

    Tried rebuilding templates and that did not help
     
  3. rainmotorsports

    rainmotorsports Well-Known Member

    If by blank page you actually got no response from the server (which the browser will usually indicate) then it sounds like the server issue we had. Almost any time the board would send an email and that email was triggered by a page that returned something to the user (registration, password reset, mass mail) the email would get sent but the server almost never acted properly.

    After testing several hosts with the same apache and php versions and arguing with tech support I figured something was up with the config. Went and configured my own server (even though we tested plenty of working hosts and no others failing us) and haven't looked back. Do not know what the cause was.
     
  4. kunik1962

    kunik1962 Member

    Still not fixed. Currently in this testing phase we are not even requiring email confirmation of registration.

    I am going to install another copy of xenforo on the server on a new database and test if it happens still on a fresh copy. That will clue me in if its a server error.
     
  5. Steve F

    Steve F Well-Known Member

    I suggest disabling all add-ons to start.

    I just tried to register and got an error but yet it did register me. The error I got before the one below was saying I didn't complete the captcha.

    Do you have any outdated templates?

    http://xlnation.net/xenforo/members/qwk86gn.169/

    upload_2014-8-26_20-42-33.png
     
  6. Hardcore

    Hardcore Active Member

    It's happening on my site right now. Out of nowhere. No clue as to why it's happening either, and we've made no changes to XF. And what's really odd is that a small fraction of users are able to register.
     
  7. Mike

    Mike XenForo Developer Staff Member

    The last time I saw something like this, it was a PHP crash due to APC. Restarting the web server or modifying some of the relevant files sorted it. (Using APC with PHP 5.4 seems to be a bad combination, causing random weirdness in certain scenarios.)
     
    Hardcore and rainmotorsports like this.
  8. Hardcore

    Hardcore Active Member

    Restarting didn't help. Using PHP w/ OpCache.
     
  9. rainmotorsports

    rainmotorsports Well-Known Member

    Mike this is the solution to the host we had a problem with when they switched to 5.4. We had no clue until now. Thank YOU!

    Anyone on shared hosting can try adding this to their .htaccess if your host uses APC/PHP5.4:
    php_flag apc.cache_by_default Off
     
    Hardcore likes this.
  10. Hardcore

    Hardcore Active Member

    @Mike: I just tried a solution similar to @rainmotorsports' by adding "php_flag opcache.enable Off" to our .htaccess file. No luck.
     
  11. Mike

    Mike XenForo Developer Staff Member

    A blank page (when it's one thing) usually indicates a PHP crash, though it could indicate a fatal PHP error. It may be worth checking your server error log for any details there or enabling error logging in php.ini to see if anything is logged there. Unfortunately, otherwise debugging something like this is quite difficult; if it came out of the blue, look for things that might have changed on the server (as an example, DNS problems appearing, mail issues, memory limits/out of memory, etc).
     
    Hardcore likes this.
  12. Hardcore

    Hardcore Active Member

    I did check our error_log. There's not much going on except for a lot of this:

    "Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 7684246 bytes) in /..path../community/library/XenForo/Model/DataRegistry.php on line 155"

    I'll look into enabling PHP error logging.

    Thanks,
     
  13. rainmotorsports

    rainmotorsports Well-Known Member

    Default script memory limit is 128 MB, I havent done the math but 134217728 looks about right. You can try increasing this if you are not on a shared host or have access to the php settings.
     
    Hardcore likes this.
  14. Hardcore

    Hardcore Active Member

    Crazy. I just upped the 'memory_limit' in php.ini from the default 128M to 256M and it fixed the issue. (I'm still curious as to the underlying reason why it caused the register page, and just the register page, to fail.)

    Thanks: @Mike @rainmotorsports for pointing me in the right direction.
     
  15. rainmotorsports

    rainmotorsports Well-Known Member

    I meant to add I believe its actually a sign of another issue when a part of Xenforo is consuming that much memory. This might help for now and all but it may still be something to look into. Did you have any addons that affect registration?
     
  16. Hardcore

    Hardcore Active Member

    We do use an add-on for sending emails, however, I turned this off during testing and the issue still persisted.

    Wondering if it's a result of a large / growing xf_user table?
     
    Last edited: Oct 26, 2014

Share This Page