• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Members rMembers replying by email instead of Private Conversation

Morgain

Well-known member
#1
I'm getting very fed up with sending out coaxing messages to members to pull them back into the community, but the way the "Email a Member" system is set up they just click Reply and it comes to me as an email.
The whole POINT is to get them to go into the community to answer me.

I put my email in the From: line because that helps get it past spam filters.
But there's no way to make it return an error message telling them to use the PC system.

Also as I have said before the design of the link to get them to login is poor. It's a pale coloured flat rectangle saying "View this Conversation"
or "View this Discussion"

That doesn't do anything to push them to click to Reply.
Nor am I as admin allowed to edit the stupid thing!

It needs to be in the CENTRE not pushed to the left. If coloured it needs to be bright blue, or red or similar. It needs to say "CLICK HERE TO REPLY"
with text underneath - "Do not click Reply on this email. Use this button to Reply."

I'm wasting a lot of effort and time here only to get lots of friendly emails from members coming back into my personal email - and they're STILL not coming to login. Why should they when all they have to do is click Reply.
They're obviously keen to respond and write paragraphs to me. But that's not the aim of my effort. Gah!
 

Andrej

Well-known member
#4
I can edit the plain text version but not the html version - which is what gets sent out by default.

Nor does that help enough when all they have to do is click Reply and it sends the reply to me as an email.
The email templates can be found in the Development tab in the Admin CP which is only accessible in debug mode.

To get the tab to appear in Admin CP, do the following:
Open up your config.php (rootforumdir/library/config.php) and put this line into the file:
Code:
$config['debug'] = true;
Save it and close. Go to your AdminCP and you'll see a new tab. "Development".
 

shawn

Well-known member
#5
Remove the body from the notification message. Set reply-to to a dead letter box. They have to come to the forum to see the message, and any inadvertent email replies go in the trash.
 

Morgain

Well-known member
#6
Remove the body from the notification message. Set reply-to to a dead letter box. They have to come to the forum to see the message, and any inadvertent email replies go in the trash.
Thank you Shawn. I actually like the content in the email. Having to visit for every notification is a chore. Just my preference. So I want to handle this another way. Thank you.
 

Morgain

Well-known member
#7
Ok I'm trying to redo the email templates.

The three things I want to do are

1. Declutter the Subject line.
I've edited the PHRASE: conversation_insert_email_subject
which was something like
{username} started a conversation with you: {title}
I've changed it to
{title} (from {username}

I want it to say eg
Hello! (from John)

But this doesn't show the sender. It shows the title but the (from ...........) becomes the board title.


2. Then I want to move all the stuff in the body which is above the content, below it.
So the email goes immediately into the sender's content. No board title blue row/ no explanations, nothing.

I tried template conversation_reply
and conversation_insert

experimented with moving just this bit to the bottom
Code:
<p style="margin-top: 0">{xen:phrase conversation_reply_email_html,
    'receiver={$receiver.username}',
    'sender=<a href="{xen:link canonical:members, $sender}" style="color: #176093; text-decoration: none">{$sender.username}</a>',
    'board=<a href="{xen:link canonical:index}" style="color: #176093; text-decoration: none">{$xenOptions.boardTitle}</a>'}</p>
Makes no difference. I still get that line at the top of the body content.

3. I made the button say CLICK TO REPLY by changing its Phrase.
But have had no luck with moving it inwards towards centre
nor with making it larger, and brighter blue.
Nor does my explanation text saying do not use email to Reply appear.

I'm not doing very well. :(
 

erich37

Well-known member
#8
I'm getting very fed up with sending out coaxing messages to members to pull them back into the community, but the way the "Email a Member" system is set up they just click Reply and it comes to me as an email.
The whole POINT is to get them to go into the community to answer me.

I put my email in the From: line because that helps get it past spam filters.
But there's no way to make it return an error message telling them to use the PC system.

Also as I have said before the design of the link to get them to login is poor. It's a pale coloured flat rectangle saying "View this Conversation"
or "View this Discussion"

That doesn't do anything to push them to click to Reply.
Nor am I as admin allowed to edit the stupid thing!

It needs to be in the CENTRE not pushed to the left. If coloured it needs to be bright blue, or red or similar. It needs to say "CLICK HERE TO REPLY"
with text underneath - "Do not click Reply on this email. Use this button to Reply."

I'm wasting a lot of effort and time here only to get lots of friendly emails from members coming back into my personal email - and they're STILL not coming to login. Why should they when all they have to do is click Reply.
They're obviously keen to respond and write paragraphs to me. But that's not the aim of my effort. Gah!
try uncheck the 2 options in ACP:

Home > Options > Email Options

- Include full message text in watched thread notification emails.
- Include full message text personal conversation notification emails.


if you show the content within the email, then surely people will reply directly ... instead of going to the forum.........
 

Morgain

Well-known member
#9
OK a little progress. MAIL_CONTAINER let me move the coloured bar with the board name from top to bottom. Yay!
Need to find there the next bundle of stuff is controlled.