1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 member cant upload avatar

Discussion in 'XenForo Questions and Support' started by Anton_Bodryachkom, Apr 8, 2015.

  1. Anton_Bodryachkom

    Anton_Bodryachkom Active Member

    Hi forum , one of the member can upload avatar , i tryed from admin end same thing , its seas , successfully uploaded, but it shows as image not there . all other members are fine . We tryed re register , same result

    that how it looks

    [​IMG]
     
  2. Martok

    Martok Well-Known Member

    Are you trying to upload just one specific image or have you tried with different images? If it's just one image then the file could be corrupt or named with the wrong file extension.
     
  3. Anton_Bodryachkom

    Anton_Bodryachkom Active Member

    different images , and i tryed same image with other user , it uploaded fine
     
  4. Anton_Bodryachkom

    Anton_Bodryachkom Active Member

    here is error

    ErrorException: getimagesize(/opt/lsws/DEFAULT/html/site.com/html/data/avatars/l/5/5256.jpg): failed to open stream: No such file or directory -library/XenForo/Model/Avatar.php:252
    Generated By: Brock Samson, Today at 2:49 AM
    Stack Trace
    #0 [internal function]: XenForo_Application::handlePhpError(2, 'getimagesize(/o...', '/opt/lsws/DEFAU...', 252, Array)
    #1 /opt/lsws/DEFAULT/html/site.com/html/library/XenForo/Model/Avatar.php(252): getimagesize('/opt/lsws/DEFAU...')
    #2 /opt/lsws/DEFAULT/html/site.com/html/library/XenForo/ControllerPublic/Account.php(587): XenForo_Model_Avatar->recropAvatar(5256, 0, 0)
    #3 /opt/lsws/DEFAULT/html/site.com/html/library/*******/Credits/ControllerPublic/Account.php(56): XenForo_ControllerPublic_Account->actionAvatarUpload()
    #4 /opt/lsws/DEFAULT/html/site.com/html/library/XenForo/FrontController.php(347): *******_Credits_ControllerPublic_Account->actionAvatarUpload()
    #5 /opt/lsws/DEFAULT/html/site.com/html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #6 /opt/lsws/DEFAULT/html/site.com/html/index.php(13): XenForo_FrontController->run()
    #7 {main}
    Request State
    array(3) {
    ["url"] => string(45) "http://www.site.com/account/avatar-upload"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(9) {
    ["use_gravatar"] => string(1) "0"
    ["su"] => string(75) "http://fc03.deviantart.net/fs71/i/2010/152/8/1/Brock_Samson_by_Injust07.jpg"
    ["avatar_date"] => string(1) "0"
    ["avatar_crop_x"] => string(1) "0"
    ["avatar_crop_y"] => string(1) "0"
    ["_xfToken"] => string(8) "********"
    ["_xfRequestUri"] => string(25) "/account/personal-details"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
    }
    }
     
  5. Anton_Bodryachkom

    Anton_Bodryachkom Active Member

    cant figure out , why its happening , any ideas?
     
  6. Martok

    Martok Well-Known Member

    There's reference to ******* Credits add-on in the error. The problem may be related to that. Try disabling the add-on and seeing if that solves the problem.
     
  7. Anton_Bodryachkom

    Anton_Bodryachkom Active Member

    I tryed , same thing , even with disabled addon
     
  8. Fred.

    Fred. Well-Known Member

    Only with avatars?
    Are you on CentOS 7? Then it can be related to this.

    I had similar problem. (with all uploads) And this fixed it.
    http://help.directadmin.com/item.php?id=561

    Also make sure the rights of the directories are set correct.
     
  9. Mike

    Mike XenForo Developer Staff Member

    Issues such as this are almost always down to incorrect permissions on the data/ directory or subdirectories or files within. You should recursively chmod this directory to 0777 if you're having an issue like this.
     
  10. Anton_Bodryachkom

    Anton_Bodryachkom Active Member

    thnx issues is fix . Mike you was right
     

Share This Page