1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 users cant upload a pic via iphone

Discussion in 'Troubleshooting and Problems' started by gavpeds, Feb 2, 2016.

  1. gavpeds

    gavpeds Active Member

    I am not sure if this is just their phones but two or three users with iphones can not upload pics to posts.

    This is from their iphone using safari. I set the limit crazy high just to rule that out so the limit is 28mb. They sent me the image via email which is actually under a MB

    I uploaded it fine to a post via my iphone but they get "File is to large for the server to process" Any ideas?
     
    Last edited: Feb 2, 2016
  2. Mike

    Mike XenForo Developer Staff Member

    That error is specifically from your php.ini setting for upload_max_filesize. This would need to be increased to support larger uploads. (It's possible that when the image was emailed to you, it was resized before sending.)
     
  3. gavpeds

    gavpeds Active Member

    Ah cheers i could have sworn i changed this. On this though does this max_upload also include videos. Reason i ask is i am using the media adon. I am not sure what a good value would be to set. I dont want to kill my server space by putting it to high but at the same time dont want it so low its frustrating members.
     
  4. Mike

    Mike XenForo Developer Staff Member

    It's a PHP-level setting that would block any upload larger than that value (before XenForo actually sees the file; we just get told there's an error). This would include videos. You can set it as high as you feel you need and then enforce size limits within XF (the temporary copy of the uploaded file would be deleted at the end of the request).
     
    gavpeds likes this.
  5. gavpeds

    gavpeds Active Member

    great thanks
     
  6. Mouth

    Mouth Well-Known Member

    Users are reporting the same issue.
    They're able to upload the exact same image (saved from google images) via desktop, but fails almost immediately, when using iPhone.
    Error given ....
    image.png

    From /admin.php?tools/phpinfo my upload_max_filesize = 48M
     
  7. Mouth

    Mouth Well-Known Member

Share This Page