MG 2.2 Media Gallery blank with FFURL

lg19

Member
I have my web host helping to figure this out right now, but I thought I would ask here as well. After enabling full friendly URLs, everything is fine except for the Media Gallery, which is just showing a blank page. Can someone tell me what step I might have missed?
 

Chris D

XenForo developer
Staff member
I suspect you have a folder called “media” in the root of your web hosting.

This will be clashing with the “media” route that XF uses to access the gallery.
 

lg19

Member
@Chris D thanks for replying so quickly. I’ve read the other similar posts and your responses, and I’ve done a search of my root directory but can’t find any folders in there called “media.” I asked my web host to search for it, and they also found these only:

[theselfi@cp23-ga ~]$ pwd
/home/theselfi
[theselfi@cp23-ga ~]$ find . -type d -iname media
./public_html/test_forum/src/addons/XFMG/InlineMod/Media
./public_html/test_forum/src/addons/XFMG/Notifier/Media
./public_html/test_forum/src/addons/XFMG/PreRegAction/Media
./public_html/test_forum/src/addons/XFMG/Pub/View/Media
./public_html/test_forum/src/addons/XFMG/Service/Media
[theselfi@cp23-ga ~]$

Should I just reinstall the Media Gallery?
 

Chris D

XenForo developer
Staff member
I'm not exactly seeing a "blank page" though.

Can you demonstrate exactly what that looks like to you? I'm seeing your "Under construction" message but that's because I'm not logged in.
 

lg19

Member
Ah, that’s because I deactivated the board. If you’ll try again, you should see a totally blank page -

Reinstalling didn’t work, and neither does disabling FFURL :(
 

Chris D

XenForo developer
Staff member
You seem to have added some custom CSS to extra.less that is explicitly hiding the entire page.

CSS:
[data-template="xfmg_media_index"], [data-template="xfmg_media_user_index"], [data-template="xfmg_category_view"] .button.button--cta {
    display: none;
}
 

lg19

Member
Oh, wow. Thanks so much for walking me through this! I was just trying to hide the “Add media” button on all those templates, as we’re using the MG only for mirroring images from posts.
 

Chris D

XenForo developer
Staff member
I think you probably want to do that with permissions.

Setting the “Add media” permissions to “No” won’t prevent mirroring from working.

If you check out our Test Mirroring media category here you will see there’s no ability to add media but media can still be mirrored to it. This is simply done with permissions for that category and not template edits.
 
Top