• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Cannot reproduce Matched Users

imthebest

Formerly Super120
#1
On a 1.4 RC2 installation using the standard search the "Matched Users" block on the search results page only appear when you perform the search being logged in. If you search as a guest that block will not be displayed.

On another 1.4 RC2 installation using the Enhanced Search 1.1.1 add-on the "Matched Users" block on the search results page only appear when you perform the search being logged in as an admin (and maybe as a mod too... haven't tested) but if you're a regular member or a guest then that block will not be displayed.

Unless I'm missing something here (like a usergroup permission) then we may have a bug here...

EDIT: just tested here and noticed that the Matched Users block always appear regardless if you're a member or a guest. And I'm pretty sure that this forum is using the ES add-on. This is a very inconsistent behavior but I'm not sure if this is a bug.
 
Last edited:

imthebest

Formerly Super120
#3
On both installations the "View member lists" permission is set to "Never" for both usergroups: Registered and Guests. Admins have the permission enabled of course.
 

Mike

XenForo developer
Staff member
#4
There is no involvement of ES here.

The code is just:
Code:
                if ($this->_getUserModel()->canViewMemberList())
                {
                    $userResults = $this->_getUserSearch($input['keywords']);
                }
                else
                {
                    $userResults = array();
                }
I still believe that it is the member list permission. Are you saying that the user name results are showing up in a case where you don't have the member list permission? (Can view view online users? If so, you have the permission.)
 

imthebest

Formerly Super120
#5
So suddenly I'm not able to reproduce this anymore... WTF!?
Really weird...

Anyway will check later and see if it happens again.