• This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

Joomla Bridge using JFusion

Coop

Active member
This bridge as released in this topic is not compatible with Joomla 1.6, it is intended to work with Joomla 1.5. There can be no compatible version with Joomla 1.6, as JFusion have not yet released a version of their software that works with Joomla 1.6.

What there is currently, is a hacked version of JFusion installed on Liz's sites. I was unaware of the problems raised in this topic http://xenforo.com/community/threads/joomla-1-6.13782/#post-192902 So those issues will be fixed. As for further development of this bridge, there is ongoing work to develop a Joomla theme that picks up the theme from XenForo, but currently that's the only additional functionality that I personally need or that Liz needs for her sites.

When I originally stepped in to write this bridge, there seemed to be a lot of interest in it from the community. Once it was written, everyone lost interest. I'm not going to continue adding features that I don't need to a bridge that nobody else is using.
 

Apokalupsis

Active member
I understand Coop. It's weird that the interest has backed off...IMO this is a very important project. Joomla is already a dominate force in the market of CMS's today, and I think it is only going to get stronger.

However, to be clear...the forums should be in the /forum director and the Joomla should be in the root for the 1.5 bridge, is this correct?
 

swatkins

Member
This bridge as released in this topic is not compatible with Joomla 1.6, it is intended to work with Joomla 1.5. There can be no compatible version with Joomla 1.6, as JFusion have not yet released a version of their software that works with Joomla 1.6.

What there is currently, is a hacked version of JFusion installed on Liz's sites. I was unaware of the problems raised in this topic http://xenforo.com/community/threads/joomla-1-6.13782/#post-192902 So those issues will be fixed. As for further development of this bridge, there is ongoing work to develop a Joomla theme that picks up the theme from XenForo, but currently that's the only additional functionality that I personally need or that Liz needs for her sites.

When I originally stepped in to write this bridge, there seemed to be a lot of interest in it from the community. Once it was written, everyone lost interest. I'm not going to continue adding features that I don't need to a bridge that nobody else is using.

I am still intrested coop... Just waiting on some money to hit the account then I will help you out :)
 

Coop

Active member
Also, with this bridge...can XF be installed in /forum directory and Joomla at the root?

I understand Coop. It's weird that the interest has backed off...IMO this is a very important project. Joomla is already a dominate force in the market of CMS's today, and I think it is only going to get stronger.

However, to be clear...the forums should be in the /forum director and the Joomla should be in the root for the 1.5 bridge, is this correct?

Just to answer this question. XF and Joomla can be installed anywhere providing the following conditions are met:

  • It must be possible to access both databases from the Joomla server (though they don't need to be the same database, nor do they need to be the same physical server).
  • For proper login integration to work, both pieces of software must be on the same domain (such as forum.example.com and joomla.example.com). For this to work, the cookie domain will need to be set to allow domain wide logins (so in this example, it would be set to .example.com) in all software linked to JFusion.
  • All software connected to JFusion must reside on the same filesystem and the server be setup to allow JFusion to directly access files from all pieces of software. So in other words, setting up seperate cpanel accounts on a server for each piece of software and enabling open_basedir would not work. But setting the software up on the same server on sub-domains would work.
Of course, all of the above would require the correct configuration. So you can install the forum in /discussions if you want or you could install the forums on the root of the site and install Joomla into a sub-directory.

The main difficulty with this will be getting everything correctly configured. Also, if you want it to work on Joomla 1.6, you will need a few patched files from me. The main problem with JFusion and Joomla 1.6 with the version released on the JFusion site is that it does not yet correctly work with the new group settings of Joomla 1.6, but I have some unofficial patches that I made to get around this. There are also a few bugs for which I have submitted patches to the JFusion repository, but those bug fixes have not yet been released (they are available in the JFusion SVN though).
 

foiovitor

Active member
I am still intrested coop... Just waiting on some money to hit the account then I will help you out :)
One more interested, sir. Just waiting to a stable 1.6 version because I'm development a custom addon - Garage System - to this version ;)
 

Apokalupsis

Active member
Of course, all of the above would require the correct configuration.
I've decided to use 1.5 for now.

However, by using this bridge, how does it affect usergroups on both platforms? If I want for instance, a usergroup for authors of content on the Joomla CMS...do I assign them as such in Joomla? If so, what happens to their usergroup on the XF end? Are the usergroups separate and as such, they'd have to be assigned to a usergroup specifically for XF as well?
 

Coop

Active member
The way user groups work depends on how things are configured. If you set Xenforo as the master, that means that user registration is done via XenForo. Once that part is configured, you can alter the Joomla configuration within JFusion to use advanced group mode. When using advanced group mode, all groups available in XenForo are listed along with a set of dropdowns. So you setup a mapping from a XenForo group to a Joomla group.

Once this is configured properly, as new users sign up, they create an account in XenForo. Then, when they navigate to a Joomla page, JFusion kicks in and automatically creates the user account for the appropriate user group and logs them into Joomla.

After that, all user accounts must be maintained in XenForo, but each time a member visits Joomla, a check is performed and if the group details have changed, the Joomla group is updated via the mapping.

Hope that makes sense.
 

Darius Studdard

New member
I'm also interested in this add on. Ive recently installed Xenforo on my Joomla site and was going to have all of my users sign up again via Xenforo. This looks like a nice way to avoid that and mesh the two systems. Will install over the weekend and test it out
 

Darius Studdard

New member
Installed and it went pretty well. Used the Usersync function in JFusion to transfer my Joomla users over to Xenforo. There seemed to be a few hiccups with that though:

  1. I had a couple of users who were considered to be active on Joomla show up as "Awaiting email confirmation" on Xenforo.
  2. Also I have a number of Joomla users in my database whose accounts were in a disabled state prior to being synced to XF. Once synced, these accounts were all in a "banned" state on the XF side. Ok..thats fine except that I get an error when trying to un-ban them saying "The requested user could not be found.". In order to un-ban them, I had to enable their accounts on the Joomla side first.
  3. I tried editing some user info on the XF side like email address and the changes are not replicated within my Joomla database.
EDIT: I also just discovered that new users trying to register are not getting the Email confirmation (with link to confirm your email address) that is required to register on my forum. They are left in the "Awaiting email confirmation" state and are not added to the list of users awaiting approval on XF.

I'm not sure if this and the errors above are because of the bridge or because of Jfusion but my users are having a lot of issues so I'm going to have to disable this for now until this is cleared up
 

Coop

Active member
Hi Darius,
to start with, I need to understand your configuration, so that I can replicate the errors you are seeing. From the above, I understand that your configuration is as follows:

  • Joomla set as master
  • Xenforo set as slave
  • Registrations disabled in Xenforo
  • Registrations enabled in Joomla
  • Sync is from Joomla to Xenforo
  • Joomla version is 1.5.x
  • Using standard Joomla login module (if using the JFusion or other login module, please let me know)

Please let me know if any of the above is wrong. Once I can replicate your issues, I'll be able to diagnose where the problem occurs (ie. in my code or JFusion) and provide appropriate fixes.
 

Darius Studdard

New member
Hi Darius,
to start with, I need to understand your configuration, so that I can replicate the errors you are seeing. From the above, I understand that your configuration is as follows:

  • Joomla set as master
  • Xenforo set as slave
  • Registrations disabled in Xenforo
  • Registrations enabled in Joomla
  • Sync is from Joomla to Xenforo
  • Joomla version is 1.5.x
  • Using standard Joomla login module (if using the JFusion or other login module, please let me know)
Please let me know if any of the above is wrong. Once I can replicate your issues, I'll be able to diagnose where the problem occurs (ie. in my code or JFusion) and provide appropriate fixes.

Hi Coop,

The email confirmation problems went away after I disabled then enabled both JFusion and the bridge on the Xenforo side. It's been working ok since then. Issues 2 and 3 are still the same.

My config is:

  • Joomla as slave
  • Xenforo as master with everything under "user options" set to Yes (sync sessions, Auto Update Activation, etc)
  • Registrations are enabled in Xenforo
  • Registrations disabled in Joomla
  • The manual sync that I did was a one time thing from Joomla to Xenforo. All users that have been added since have been on the Xenforo side.
  • Joomla 1.5.15
  • Yes, standard Joomla login is being used.
Heres a copy/paste of login checker (with some of my info X'd out):
===========================================================================
JFusion Login Checker Results

Server Configuration
Joomla Version 1.5.15
PHP Version 5.2.17
MySQL Version 5.1.47-community-log
System Information Linux host378.hostmonster.com 2.6.32-29.1.BHsmp #1 SMP Wed Feb 23 10:03:17 MST 2011 x86_64
Browser Information Opera/9.80 (Windows NT 6.1; U; en) Presto/2.8.131 Version/11.10
openid authentication Plugin Enabled
deleteuser user Plugin Enabled
jcomments user Plugin Enabled
jfusion user Plugin Enabled
jfusion authentication Plugin Enabled

JFusion Versions
JFusion Component Version 1.5.5-000 (Rev 2442:2452)
JFusion Authentication Plugin Version 1.5.5-000
JFusion User Plugin Version 1.5.5-000
JFusion Activity Module Version 1.5.5-000
JFusion Login Module Version 1.5.5-000
JFusion Search Plugin Version 1.5.5-000
JFusion Discussion Plugin Version 1.5.5-000

JFusion xenforo Plugin
configuration master 1
slave 3
dual_login 3
check_encryption 1
JFusion joomla_int Plugin
configuration master 0
slave 1
dual_login 1
check_encryption 1

Authentication Plugin
userid 1
name xxxxxxxxxxx
username xxxxxxxxxxx
block 0
remember_key 7b02e72cca0ac3ed9b85150477eb2a0f216f175a
email xxxxxxxxxxx
group_id 2
authinfo a:3:{s:4:"hash";s:64:"79a63cffbcc6021ebf4772b08c6df664b95300920d9251d41a706effcd1d95f8";s:4:"salt";s:64:"ee94285f1207a8d761081b3d40ee0bf7aaee577fe94f99f511c5407593315072";s:8:"hashFunc";s:6:"sha256";}
user_state valid
scheme_class XenForo_Authentication_Core
activation ""
reason ""
user_type ""
membergroupids 3,4
password 79a63c********
password_salt ee94*****
hashFunc sha256
group_name Registered
credentialed_username xxxxxxxxxxx
password_clear ******
Authentication Plugin Success
Authentication Plugin Debug
0 xenforo Password Encryption Check: 79a63c******** vs 79a63c********
1 xenforo Password Encryption Check: Success

jfusion User Plugin
User Plugin Success
User Plugin Debug
init 0 Using userinfo JFusion authentication plugin
joomla_int User Update 0 A user has been found that matches the login details
1 Skipped Password Update: Password already valid
2 Language of the user not updated: en-GB ->
joomla_int User Details userid 67
activation ""
username xxxxxxxxxxx
name Darius Studdard
password e6446b********
email xxxxxxxxxxx
block 0
group_name Administrator
group_id 24
params admin_language= language= editor= helpsite= timezone=-5
password_salt 9e9P*****
language en-GB
password_clear ******
xenforo Session 0 Plugin XenForo:: Entering user->createSession
1 Plugin XenForo:: entering function helper->deleteSession
2 Plugin XenForo::helper->deleteSession deleting session_id 055788a5b37aeb0d2346173ff41fb77c from database
3 Plugin XenForo::helper->deleteSession deleting XenForo session cookie 055788a5b37aeb0d2346173ff41fb77c
4 Plugin XenForo::helper->deleteSession deleting XenForo user cookie 1,13409f4b93b1a858d6efe774d553d039a55dc625
5 Plugin XenForo:: Leaving function helper->deleteSession
6 Plugin XenForo:: entering function helper->createSession
7 Plugin XenForo:: helper->createSession new session_id = 93546c52821bcc945704efb8c7142b99
8 Plugin XenForo:: helper->createSession inserting session record into xf_session table
9 Plugin XenForo:: helper->createSession setting session cookie
10 Plugin XenForo:: helper->createSession setting remember key
11 Plugin XenForo:: helper->createSession setting remember key cookie to 1,13409f4b93b1a858d6efe774d553d039a55dc625
12 Plugin XenForo:: Leaving user->createSession
joomlaid 67
 

Coop

Active member
I am aware of these issues and am looking into a solution. But right now in South Africa, it is the easter holidays and much of my time is occupied with my family. At this point, I have confirmed that item 2 is an issue, but involves functionality that JFusion does not support (apparently, syncing emails is only supported with Joomla as master). I also have a potential solution for this issue (though it still requires a little more work).

For item 3, I have not yet had the time to reproduce the problem, but that seems to be a lower priority issue anyway.
 

Darius Studdard

New member
One additional thing that I just noticed. When I click on the profiles of any members that I transfered over to XF from Joomla, it shows that they've been members since Dec 31, 1969. I would think it should either show the date that I transfered them over to XF or the date they became members in Joomla.
 

FredC

Well-known member
When I originally stepped in to write this bridge, there seemed to be a lot of interest in it from the community. Once it was written, everyone lost interest. I'm not going to continue adding features that I don't need to a bridge that nobody else is using.
Sorry Coop, I havent even had a chance to try the bridge as i had no choice but to move away from Joomla with XF before this became available.. at the moment i only have one forum with Joomla as a CMS and its a vB forum so maybe in the future i will be able to find a use for this.. Anyways i do appreciate you stepping in and getting this project off the ground.. Unfortunately for me personally i lost interest a long time ago and had to find alternative solutions.
 

Digital Doctor

Well-known member
Anyone know ?
Is it possible to create usergroup permission integration with Joomla?
I think this will work for Joomla 1.6 jfusion which is being alpha'd right now.

Is it possible to integrate new content so that 'what's new' shows Images, forum and Joomla content? Could sphinx be used for this?
It was possible to have forum threads appear when using Joomla search (Depending on the forum in question). I do not think the reverse is possible ... it Joomla content can show up in Forum searching.
 
Top