• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Issues with rebuilding "Template Caches"

#1
Hey there, I have been having some issues trying to rebuild the Templates Cache when ever I install a addon or change something with Template Modification System (TMS)

This it the order at which things happen
Rebuilding Caches...
Rebuilding... Templates
Rebuilding Caches...
An error occurred or the request was stopped.
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@********* and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
I have disabled all addons, enabled debug, set enableListeners to false, and set display_errors to true
I have no errors that come in the APC "tools/Server Error Logs" or the cPanel "error log"
I have also sent a ticket in the the host service (Name.com) to see if it is something on there end

Next step is to start removing addons at this point if there is nothing else I can do
I also do not have a backup - Fairly new site that I could rebuild again with TMS export (hopefully)

Thanks :)
 

Brogan

XenForo moderator
Staff member
#2
Try viewing the page source to see if any other details are available when the error occurs.

Unlikely but it's worth a try.
 
#5
It's your server lacks/limits resoruces.
Thank you, I will confirm with hosting

Was working fine a few weeks ago then I started to make some TMS edits then it started happening
Edits were going live but when I started to install new addons, they would break :/
 

Mike

XenForo developer
Staff member
#7
Hey, I've actually watched you on Twitch before. :)

TMS does change the rebuild process IIRC. Go to <url>/install/ and rebuild the master data there. Can you get through that? If so, there may be some indication of TMS being involved. (Though if you trigger the cache rebuild with enableListeners = false in the config, you shouldn't be affected by it.)

How many styles do you have on your board? (Even disabled ones.) How many languages do you have? If you can reduce either of those, that will make the process faster.

Finally, 1.2 does significantly change the template rebuild process and it's usually faster, though obviously if you have a bunch of add-ons, you'd want to confirm that they're compatible with 1.2.
 
#9
Are you on shared hosting, vps or dedicated?

How many styles do you have installed?
Shared and 4 (default, Flexile standalone, Flexile dark, Flexile dark TEST)

Hey, I've actually watched you on Twitch before. :)

TMS does change the rebuild process IIRC. Go to <url>/install/ and rebuild the master data there. Can you get through that? If so, there may be some indication of TMS being involved. (Though if you trigger the cache rebuild with enableListeners = false in the config, you shouldn't be affected by it.)

How many styles do you have on your board? (Even disabled ones.) How many languages do you have? If you can reduce either of those, that will make the process faster.

Finally, 1.2 does significantly change the template rebuild process and it's usually faster, though obviously if you have a bunch of add-ons, you'd want to confirm that they're compatible with 1.2.
Nice, hope you enjoyed your self while you were there :)

Was able to get there but sadly was not able to rebuild it - Crashed at the same point (now the layout of the /admin is almost unusable)
Total of 4 styles (list above)
Default language of English

And I have been looking at getting 1.2 but Flexile hasn't been updated yet for it but I have been testing it and loving it on a local machine

I think only Shared Hosting is available @ Name.com
You can get VPS but I was looking to downgrade and have run xenforo on Shared before with InMotion Hosting
 

Mike

XenForo developer
Staff member
#10
If you want to submit a ticket with admin CP access and FTP access details, I can look into determining the cause. I suspect that the server may just be killing the PHP process.
 
#11
If you want to submit a ticket with admin CP access and FTP access details, I can look into determining the cause. I suspect that the server may just be killing the PHP process.
Finally got a ticket response and I am being told that I am using my CPU resources and to look in to my cache settings and see if a plugin or script is causing this

submitting a ticket now for you