XF 1.1 Getting stuck with Rebuilding Caches...

Gopala Subramanium

Active member
Hi, please help, my site is down. I had tried to update XenFacil Birthday Greetings addon through the new "Add-on Install & Upgrade", it got stuck and since then am getting error rebuilding caches. I have disabled all the add-ons but still the rebuilding is getting stuck on the template screen. Please help, very important.

Thankyou so much in advance.
 

Jake Bunce

XenForo moderator
Staff member
What error?

1) Remove any excess styles or languages that you aren't using. That will speed up the rebuild.

2) You can try adding this line to your library/config.php file to increase the timeout (default is 10):

Code:
$config['rebuildMaxExecution'] = 10;
3) Or just refresh the page until it finishes the rebuild.
 

Gopala Subramanium

Active member
Thanks Jake, after a lot of try i went to rebuild core master data. Here also same, Permissions & Phrases are building but getting error in building the templates, i.e., exactly the same error i'm getting in rebuilding normally :(
 

Gopala Subramanium

Active member
Got hold of the error, any suggections:

Server Error Log

Error Info
Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Deadlock found when trying to get lock; try restarting transaction - library/Zend/Db/Statement/Mysqli.php:214
Generated By: sgopala, 48 minutes ago
Stack Trace
#0 /home/content/93/9706293/html/FMS_Forum/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /home/content/93/9706293/html/FMS_Forum/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /home/content/93/9706293/html/FMS_Forum/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
#3 /home/content/93/9706293/html/FMS_Forum/library/XenForo/Model/Template.php(1268): Zend_Db_Adapter_Abstract->insert('xf_template_map', Array)
#4 /home/content/93/9706293/html/FMS_Forum/library/XenForo/CacheRebuilder/Template.php(38): XenForo_Model_Template->insertTemplateMapForStyles(Array, true)
#5 /home/content/93/9706293/html/FMS_Forum/library/XenForo/ControllerHelper/CacheRebuild.php(26): XenForo_CacheRebuilder_Template->rebuild(0, Array, NULL)
#6 /home/content/93/9706293/html/FMS_Forum/library/XenForo/ControllerAdmin/Tools.php(78): XenForo_ControllerHelper_CacheRebuild->rebuildCache(Array, 'admin.php?style...', 'admin.php?tools...', true)
#7 /home/content/93/9706293/html/FMS_Forum/library/XenForo/FrontController.php(310): XenForo_ControllerAdmin_Tools->actionCacheRebuild()
#8 /home/content/93/9706293/html/FMS_Forum/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#9 /home/content/93/9706293/html/FMS_Forum/admin.php(13): XenForo_FrontController->run()
#10 {main}
Request State
array(3) {
["url"] => string(65) "https://www.fixmystuff.in/FMS_Forum/admin.php?tools/cache-rebuild"
["_GET"] => array(1) {
["tools/cache-rebuild"] => string(0) ""
}
["_POST"] => array(5) {
["process"] => string(1) "1"
["caches"] => string(12) "["Template"]"
["position"] => string(1) "0"
["redirect"] => string(17) "admin.php?styles/"
["_xfToken"] => string(53) "1,1363311398,3599c07e3de778779da9f74c765219f481c10324"
}
 

Gopala Subramanium

Active member
Server Error Log

Error Info
ErrorException: Undefined index: is_banned - library/BannedAvatar/Listener.php:84
Generated By: Unknown Account, Today at 5:56 AM
Stack Trace
#0 /home/content/93/9706293/html/FMS_Forum/library/BannedAvatar/Listener.php(84): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/content/9...', 84, Array)
#1 /home/content/93/9706293/html/FMS_Forum/library/BannedAvatar/Listener.php(57): BannedAvatar_Listener::_getDefaultAvatarUrl(Array, 'm')
#2 /home/content/93/9706293/html/FMS_Forum/library/BannedAvatar/Listener.php(33): BannedAvatar_Listener::getAvatarUrl(Array, 'm', NULL)
#3 [internal function]: BannedAvatar_Listener::helperAvatarUrl(Array, 'm', NULL, false)
#4 /home/content/93/9706293/html/FMS_Forum/library/XenForo/Template/Helper/Core.php(1560): call_user_func(Array, Array, 'm', NULL, false)
#5 /home/content/93/9706293/html/FMS_Forum/library/XenFacil/BirthdayGreetings/Model/Usuario.php(7): XenForo_Template_Helper_Core::helperAvatarHtml(Array, 's')
#6 /home/content/93/9706293/html/FMS_Forum/library/XenFacil/BirthdayGreetings/Model/Usuario.php(53): XenFacil_BirthdayGreetings_Model_Usuario->_getAvatarUser(Array)
#7 /home/content/93/9706293/html/FMS_Forum/library/XenFacil/BirthdayGreetings/CronEntry/Birthdays.php(26): XenFacil_BirthdayGreetings_Model_Usuario->_getUserBirthday('0')
#8 [internal function]: XenFacil_BirthdayGreetings_CronEntry_Birthdays::runFelicidades(Array)
#9 /home/content/93/9706293/html/FMS_Forum/library/XenForo/Model/Cron.php(356): call_user_func(Array, Array)
#10 /home/content/93/9706293/html/FMS_Forum/library/XenForo/Cron.php(29): XenForo_Model_Cron->runEntry(Array)
#11 /home/content/93/9706293/html/FMS_Forum/library/XenForo/Cron.php(64): XenForo_Cron->run()
#12 /home/content/93/9706293/html/FMS_Forum/cron.php(12): XenForo_Cron::runAndOutput()
#13 {main}
Request State
array(3) {
["url"] => string(55) "https://www.fixmystuff.in/FMS_Forum/cron.php?1363307199"
["_GET"] => array(1) {
[1363307199] => string(0) ""
}
["_POST"] => array(0) {
}
}
 

Gopala Subramanium

Active member
Server Error Log

Error Info
XenForo_Exception: Got unexpected, non-string/non-array segments for compilation. - library/XenForo/Template/Compiler.php:364
Generated By: sgopala, Today at 6:23 AM
Stack Trace
#0 /home/content/93/9706293/html/FMS_Forum/library/XenForo/Model/Template.php(1097): XenForo_Template_Compiler->compileParsed(false, 'account_persona...', 1, 1)
#1 /home/content/93/9706293/html/FMS_Forum/library/TMS/Model/Template.php(183): XenForo_Model_Template->compileAndInsertParsedTemplate(1293, false, 'account_persona...', 1)
#2 /home/content/93/9706293/html/FMS_Forum/library/TMS/Model/Template.php(155): TMS_Model_Template->compileAndInsertParsedTemplate(1293, Array, 'account_persona...', 1)
#3 /home/content/93/9706293/html/FMS_Forum/library/XenForo/CacheRebuilder/Template.php(55): TMS_Model_Template->compileAllTemplates(19.442450046539, 0, 0)
#4 /home/content/93/9706293/html/FMS_Forum/library/XenForo/ControllerHelper/CacheRebuild.php(26): XenForo_CacheRebuilder_Template->rebuild(0, Array, NULL)
#5 /home/content/93/9706293/html/FMS_Forum/library/XenForo/ControllerAdmin/Tools.php(78): XenForo_ControllerHelper_CacheRebuild->rebuildCache(Array, 'admin.php?add-o...', 'admin.php?tools...', true)
#6 /home/content/93/9706293/html/FMS_Forum/library/XenForo/FrontController.php(310): XenForo_ControllerAdmin_Tools->actionCacheRebuild()
#7 /home/content/93/9706293/html/FMS_Forum/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#8 /home/content/93/9706293/html/FMS_Forum/admin.php(13): XenForo_FrontController->run()
#9 {main}
Request State
array(3) {
["url"] => string(65) "https://www.fixmystuff.in/FMS_Forum/admin.php?tools/cache-rebuild"
["_GET"] => array(1) {
["tools/cache-rebuild"] => string(0) ""
}
["_POST"] => array(8) {
["process"] => string(1) "1"
["caches"] => string(44) "["Template","AdminTemplate","EmailTemplate"]"
["position"] => string(1) "0"
["redirect"] => string(18) "admin.php?add-ons/"
["_xfToken"] => string(53) "1,1363308731,3f35c4cd17db0bcfe76db5e146474471c3632b57"
["_xfRequestUri"] => string(40) "/FMS_Forum/admin.php?tools/cache-rebuild"
["_xfNoRedirect"] => string(1) "1"
["_xfResponseType"] => string(4) "json"
 

Jake Bunce

XenForo moderator
Staff member
Mysqli statement execute error : Deadlock found when trying to get lock; try restarting transaction
If refreshing the page doesn't fix that error then Mike's post might be helpful:

As far as I can read, deadlocking shouldn't happen there. Depending on your MySQL version, you may be able to set innodb_autoinc_lock_mode to 1 via my.cnf (http://dev.mysql.com/doc/refman/5.1/en/innodb-auto-increment-handling.html) and that may get rid of many of the deadlocks.
 

Jake Bunce

XenForo moderator
Staff member
Undefined index: is_banned - library/BannedAvatar/Listener.php:84
That error is not related to the cache rebuild. If you wish to address that error from your log then you should contact the author of the BannedAvatar addon.
 
Top