• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Is xf_session table supposed to be empty?

LPH

Well-known member
#1
I noticed that the xf_session is always empty. The xf_session_activity has data but the xf_session_admin is also empty.

Is this normal?

Update: I just checked my local installation and there is an entry. :(
 

LPH

Well-known member
#3
But I am logged into the forum :(

I log into the forum, check database, and nothing changes. In contrast, the local install updates immediately.
 

LPH

Well-known member
#6
Thank you both for replying. No, I'm not using memcache.

Could the database table be corrupt? I've tried a repair, tried to compare local and live tables for xf_session and they look the same.
 

Jake Bunce

XenForo moderator
Staff member
#7
Are you using any cache at all? APC, memcache, file, etc. It would be defined in your library/config.php file.

Or maybe you are looking at the wrong database?
 

LPH

Well-known member
#11
My xf_session table is also empty but we store sessions in cache using APC.. do you use a cache extension?
The /library/config.php has

Code:
$config['cache']['enabled'] = true;
$config['cache']['cacheSessions'] = true;
$config['cache']['backend'] = 'File';
$config['cache']['backendOptions'] ['cache_dir'] = '/path/to/tuxreportsnetwork.com/community/internal_data/cache';
$config['cache']['frontend'] = 'Core';
$config['cache']['frontendOptions']['cache_id_prefix'] = 'xf_';
 
$config['cache']['backend'] = 'File';
$config['adminLogLength'] = 30;
So, maybe I should be looking into that folder to see the sessions are being written there.

Update: Oh my ! There are tons of files in that folder ending with the session. Very cool. Sad news for my idea on something else. Oh well.
 

Onimua

Well-known member
#14
Not sure that's correct.

There's an xf_session_admin table for ACP sessions.
I just tried it on my localhost before I posted that and found it to be true in that instance. I didn't look too deep past that, only found one thing that didn't leave it empty. Clearly it seems something that's setting-based.
 

Jeremy P

Well-known member
#15
I just tried it on my localhost before I posted that and found it to be true in that instance. I didn't look too deep past that, only found one thing that didn't leave it empty. Clearly it seems something that's setting-based.
As above, it's because sessions are being stored in the cache because of how config.php is set.
 

Cool

Active member
#16
may usefull for them wich may integrate the blab chat(http://hot-things.net/)
the session cache has to be set to "false" otherweise the chat is not able to get the session id for the users.

may the chat-programmer change that in future.