1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Installing themes error

Discussion in 'Troubleshooting and Problems' started by Halt03410, Aug 5, 2016.

  1. Halt03410

    Halt03410 New Member

    So when I attempt to install or update themes on my forums I get and error saying Compiler.php didn't function properly. And it creates this error in my error logs

    Code:
    Error Info
    XenForo_Template_Compiler_Exception: editor_contents.css - Line 80: Invalid math expression - library/XenForo/Template/Compiler.php:991
    Generated By: Halt, Today at 5:45 AM
    Stack Trace
    #0 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Template/Compiler/Function/Calc.php(189): XenForo_Template_Compiler->getNewCompilerException(Object(XenForo_Phrase))
    #1 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Template/Compiler/Function/Calc.php(55): XenForo_Template_Compiler_Function_Calc->_parseMathExpression(Object(XenForo_Template_Compiler), 'intval(?) + int...', Array)
    #2 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Template/Compiler.php(700): XenForo_Template_Compiler_Function_Calc->compile(Object(XenForo_Template_Compiler), 'calc', Array, Array)
    #3 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Template/Compiler.php(576): XenForo_Template_Compiler->compileFunction('calc', Array, Array)
    #4 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Template/Compiler.php(509): XenForo_Template_Compiler->compileSegment(Array, Array)
    #5 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Template/Compiler/Tag/If.php(112): XenForo_Template_Compiler->compileSegments(Array, Array)
    #6 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Template/Compiler.php(641): XenForo_Template_Compiler_Tag_If->compile(Object(XenForo_Template_Compiler), 'if', Array, Array, Array)
    #7 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Template/Compiler.php(570): XenForo_Template_Compiler->compileTag('if', Array, Array, Array)
    #8 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Template/Compiler.php(509): XenForo_Template_Compiler->compileSegment(Array, Array)
    #9 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Template/Compiler.php(422): XenForo_Template_Compiler->compileSegments(Array, Array)
    #10 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Template/Compiler/Tag/Include.php(113): XenForo_Template_Compiler->compileIntoVariable(Array, '__compilerVar3', Array)
    #11 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Template/Compiler.php(641): XenForo_Template_Compiler_Tag_Include->compile(Object(XenForo_Template_Compiler), 'include', Array, Array, Array)
    #12 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Template/Compiler.php(570): XenForo_Template_Compiler->compileTag('include', Array, Array, Array)
    #13 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Template/Compiler.php(509): XenForo_Template_Compiler->compileSegment(Array, Array)
    #14 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Template/Compiler.php(372): XenForo_Template_Compiler->compileSegments(Array)
    #15 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Model/Template.php(1601): XenForo_Template_Compiler->compileParsed(Array, 'editor_contents...', 9, 0)
    #16 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Model/Template.php(1480): XenForo_Model_Template->compileAndInsertParsedTemplate(1233, Array, 'editor_contents...', 9)
    #17 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Model/Template.php(1329): XenForo_Model_Template->compileTemplateInStyleTree(Array)
    #18 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Model/Template.php(1268): XenForo_Model_Template->compileNamedTemplateInStyleTree('editor_contents...', 0)
    #19 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Deferred/Template.php(36): XenForo_Model_Template->compileAllTemplates(1.561546087265, 0, 0)
    #20 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_Template->execute(Array, Array, 2.2919840812683, 'Rebuilding... T...')
    #21 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 2.2919840812683, 'Rebuilding... T...', false)
    #22 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 2.2919869422913, 'Rebuilding... T...', false)
    #23 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/ViewRenderer/Abstract.php(352): XenForo_Model_Deferred->run(true, 2.2919869422913)
    #24 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/ViewRenderer/HtmlAdmin.php(50): XenForo_ViewRenderer_Abstract::hasManualDeferredToRun()
    #25 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/FrontController.php(616): XenForo_ViewRenderer_HtmlAdmin->renderRedirect(4, 'http://forums.b...', NULL, Array)
    #26 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_Redirect), Object(XenForo_ViewRenderer_HtmlAdmin), Array)
    #27 /var/www/vhosts/blacksunstudios.org/forums.blacksunstudios.org/admin.php(13): XenForo_FrontController->run()
    #28 {main}
    Request State
    array(3) {
      ["url"] => string(68) "http://forums.blacksunstudios.org/admin.php?uix-styles/install-step2"
      ["_GET"] => array(1) {
        ["uix-styles/install-step2"] => string(0) ""
      }
      ["_POST"] => array(0) {
      }
    }
    I'm not familiar with Xenforo at all so I have not much of an idea as to what I should do from here. Any help is appreciated.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    That's an issue with the UI.X style - you will have to contact the author for support.
     
  3. Mike

    Mike XenForo Developer Staff Member

    This particular error indicates that you're trying to install a newer theme on an older XenForo. You need to upgrade to XenForo 1.5.9.
     

Share This Page