1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Installing an unsupported addon, user permissions not showing up

Discussion in 'Troubleshooting and Problems' started by Soliloquy, Mar 23, 2016.

  1. Soliloquy

    Soliloquy Member

    I've been trying to install the unsupported EggAvatar addon, and though the user options for most of it appear in my admin panel, the user group permissions do not. I suspect what's why nothing is showing up on the front-end. I thought I'd be able to go into the database and set the user group permissions manually, but couldn't figure out how the tables worked or my plug-in's addon_id. (I looked in the XML file, but the only addon_id field is the name of the plug-in itself, not the random-looking string of letters and numbers in the tables.)

    Could anyone point me towards resources on how to understand the user group permissions tables, or how to figure out what my plug-in's ID would be?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    You can't manipulate permissions directly in the database.

    It sounds like the add-on may need to be updated, which would be the best way of resolving the issue.
     
  3. Soliloquy

    Soliloquy Member

    Pretty sure the author isn't going to do that.

    Hmm… alternatively, maybe there's a way to get the user permissions block to show up in the admin panel? The code for that should be in the XML file right? I'm not sure what I'm looking for.
     
  4. Kevin

    Kevin Well-Known Member

    I haven't tried it lately but feedback I was getting was that it was still working up till the 1.5.x release.

    I'll update my test install to 1.5.6 and see if I run into any issues.
     
  5. Soliloquy

    Soliloquy Member

    Oh, wow. I had no idea you'd show up. Thank you!

    I know somebody else got it installed recently, which is why I was trying again. I don't know why theirs worked and mine didn't. (I re-downloaded and re-uploaded the files, just in case something got corrupted, to no avail.)

    Let me know if you need anything from me.
     
  6. Kevin

    Kevin Well-Known Member

    Greetings. It's taken a few nights (coming home late from the office) but I've updated my prod & test sites to 1.5.6 and installed the 1.0 release of Egg Avatar to check it out.

    The short answer... there are no user group permissions. :oops:
    Code:
      <permissions>
        <permission_groups/>
        <permissions/>
        <interface_groups/>
      </permissions>
    
    There are only three places to change stuff in the ACP.

    ACP => Home => Egg Avatar -- Used to add/remote images.

    ACP => Home => Options => Egg Avatar -- Used to set what forums where avatars can be egged, exclude specific users, ban specific users, clean avatars, and set time limit between throws.

    ACP => Tools => Egg Avatar Log -- Simple log of activity​

    What type of user group level permissions where you looking for? Basic what groups can/can't throw items or something more advanced?
     
  7. Soliloquy

    Soliloquy Member

    Hi Kevin, thanks for looking into this for me. It wasn't that I needed to exclude any user groups on using the plug-in, it was that I thought that was the last thing preventing the plug-in from working on my site. If the "throw" link is supposed to show up automatically, it didn't in mine. If we're supposed to perform the template edit manually, I didn't find instructions for doing so.
     

Share This Page