• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed installation error

Affected version
2.0.0

Chris D

XenForo developer
Staff member
#22
We've seen other reports of this, hence I've moved your post there.

Something is causing the installation code to fall over with a code 500 internal server error.

Ideally we'd need you to look within your web server / PHP logs to see if there's any reason being logged internally there.

Otherwise, you'd need to submit a ticket with FTP and Admin CP details and we'll look into it for you.
 

Chris D

XenForo developer
Staff member
#25
@Shane Greer I have replied to your ticket and the issue has been resolved.

@faik02 @ratix_gunz the problem in this particular case was as follows:
Code:
[E_WARNING] set_time_limit() has been disabled for security reasons
With the behaviour being almost identical, and considering the code we run that early on, I do suspect it could be the same cause.

Please check (your host might be able to help) that set_time_limit() is not disabled in PHP.
 
#28
Same error - clean 2.0 install (versions 1.5.x were ok):
An exception occurred: [ErrorException] [E_WARNING] set_time_limit() has been disabled for security reasons in src/XF/Install/App.php on line 123
My hosting disabled set_time_limit() PHP function - why we need it in XenForo version 2.0?
EDIT: answer from my hosting: "set_time_limit() is disabled here."
I really don't want change hosting or run VPS due to the function set_time_limit().
 
Last edited:

Chris D

XenForo developer
Staff member
#29
We used set_time_limit in XF1 too but we silence any errors.

Frankly it’s a ludicrous function to disable.

That said in the next release we have silenced it too.

To resolve it now you would need to search the code for usages if that and put an @ character in front of it.
 

Mike

XenForo developer
Staff member
#30
As mentioned, 2.0.1 fixes this, though we now warn if this function is disabled. To be honest, disabling this function seems to indicate that your host isn't trusting that you know when to use it -- and there are instances where longer run times are needed and totally legitimate.

If you want to workaround it on 2.0.0 and can't get that function enabled, in src/XF/Install/App.php, change:
Code:
set_time_limit(0);
to:
Code:
@set_time_limit(0);