• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Install Problems


Active member
I am trying to install xenforo and have been having problems for 3 days, I have an error. I have spent over 4 hours trying to install it in the last 3 days.

String could not be parsed as XML

  1. SimpleXMLElement->__construct()inXenForo/Deferred/ImportPhrase.phpat line0
  2. XenForo_Deferred_ImportPhrase->execute()inXenForo/Deferred/Atomic.phpat line61
  3. XenForo_Deferred_Atomic->execute()inXenForo/Model/Deferred.phpat line208
  4. XenForo_Model_Deferred->runDeferred()inXenForo/Model/Deferred.phpat line331
  5. XenForo_Model_Deferred->_runInternal()inXenForo/Model/Deferred.phpat line265
  6. XenForo_Model_Deferred->runByUniqueKey()inXenForo/Install/Controller/Abstract.phpat line34
  7. XenForo_Install_Controller_Abstract->_manualDeferredRunner()inXenForo/Install/Controller/Install.phpat line221
  8. XenForo_Install_Controller_Install->actionRunDeferred()inXenForo/FrontController.phpat line337
  9. XenForo_FrontController->dispatch()inXenForo/FrontController.phpat line134
  10. XenForo_FrontController->run()in/home/namephas/public_html/dntalks.com/xen/install/index.phpat line18
I have deleted all files and re uploaded many times. I have tried to overwrite files, I have downloaded WinSCP and uploaded, I have done it through cPanel File Manager, I have uploaded it with Firezilla.

What is the problem?


Active member
Which file and how do I fix it?

I am uploading 1.0 right now and if I can get it to install I will just upgrade till I get it working. If I can do it that way but which file would be corrupted because I have uploaded Xenforo at least 4-5 times now maybe more.
Yes the server met all requirements.

I have fixxed the install problem, but now when it installs it says it wants to upgrade. Although this install is 1.2.2. How do I fix that?


Well-known member
If it is requesting an upgrade it means the versions do not match up. What version does it say in the top left hand corner of your ACP?
Admin Control Panel - XenForo
The board is currently waiting to be upgraded. Please complete the upgrade.

When I click on complete the upgrade it reinstalls xenforo 1.2.2


XenForo developer
Staff member
If you are doing an install and you never completed it, the system was put into a slightly confused state so it shows that message to cover up any errors. Just complete the installation process from the beginning and it should be fine.
Well I kept reuploading till it worked and now its giving errors again since I deleted it and reuploaded it to make it stop upgrading. But ill mess with it more tonight. I want my forum on xenforo.

Digital Doctor

Well-known member
Can't there be some MD5 checking ?

Upload the entire xenforo.zip and then check the MD5 of the file ?

It's probably more reliable to upload xenforo as one file and then extract it on the server.
I am re-uploading and will go through the steps needed to get it working. I appreciate you helping me. I have just downloaded and extracted a new copy of xen 1.2.2 and am uploading with firezilla now. I have also tried.

Uploaded the zip and extracting on the server, I have tried Winscp.
The server is cpanel and has the requirements to run xen by the xenforo test.

So We will see what happens....