1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Install or Upgrade?

Discussion in 'Installation, Upgrade, and Import Support' started by Vidmarc, Nov 7, 2013.

  1. Vidmarc

    Vidmarc Member

    I've just downloaded the 1.2.3 upgrade but the upgrade page says I need to upgrade via forum/install.

    Is this correct? Shouldn't there be an upgrade only option? Before I continue I need to confirm thiat what I'm doing is OK.

     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    From the FAQ:

    I am trying to upgrade but it is attempting to do a new installation, how do I proceed without overwriting the existing data?
    It's possible you have uploaded the files from the full package, rather than the upgrade package. Or you have uploaded the correct files but to the wrong location. Check that your data and internal_data directories have not been overwritten. If they have, you will need to restore the files from a backup. To continue with the upgrade, you will need to ensure the correct details are in library/config.php and replace the internal_data/install-lock.php file.

    http://xenforo.com/community/threads/frequently-asked-questions.5183/#post-282417
     
  3. Vidmarc

    Vidmarc Member

    I actually downloaded the Upgrade package, which is also labelled as such. This has me worried now. I've no idea what to do.

    The Upgrade folder includes the Data folder. Not sure where Internal Data is.

    What should I do now? I don't understand.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    It shouldn't - mine doesn't.
    The four top level directories in the upgrade .zip should just be: install, js, library, styles.
     
  5. Vidmarc

    Vidmarc Member

    My upgrade package includes:

    admin.php
    admindav.php
    css.php
    deferred.php
    fb_channel.php
    htaccess.txt
    index.php
    install/
    js/
    library/
    payment_callback.php
    rgba.php
    styles/

    install/Data/ includes:

    admin_navigation.xml
    admin_permissions.xml
    admin_style_properties.xml
    admin_templates.xml
    code_events.xml
    cron.xml
    email_templates.xml
    index.html
    options.xml
    permissions.xml
    phrases.xml
    route_prefixes.xml
    style_properties.xml
    templates.xml

    Does this mean I'm OK? What is my next step?
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

  7. Vidmarc

    Vidmarc Member

    I'd already removed it as it said in the install instructions.
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

  9. Vidmarc

    Vidmarc Member

    It said to remove it to continue the upgrade if I kept getting the Install only option.

    I keep getting the install option and not the upgrade option.

    Confused.

     
  10. Jeremy

    Jeremy XenForo Moderator Staff Member

    You need the install lock file, restore it.
     
  11. Vidmarc

    Vidmarc Member

    From where? I don't have a back up.
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    Just create one with something like this in it:
    Code:
    <?php header('Location: ../index.php'); /* Installed: Tue, 19 Mar 13 00:00:23 +0000 */
     
  13. Vidmarc

    Vidmarc Member

    Done, but again now...

    :-(
     
  14. Andrej

    Andrej Well-Known Member

    Navigate to /install/index.php?upgrade/. That error is showing you are on install/index.php?install.
     
  15. Brogan

    Brogan XenForo Moderator Staff Member

    Then it sounds like you have not uploaded the files to the correct location.
     
    Vidmarc likes this.
  16. Vidmarc

    Vidmarc Member

    Thanks for your help and patience Brogan. All is now well. :)
     

Share This Page