• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Cannot reproduce Infinite redirect in upgrade

Jeremy

Well-known member
#1
I had a link open (posts/89/) on my system, and when I finished upload, I decided it wouldn't hurt to just reload and get to the upgrade.. Well, it infinite loop redirects to /install/install/install/etc...
 

Mike

XenForo developer
Staff member
#2
I can't say I follow this. The only silent redirect to the install directory is when the config.php doesn't exist, but you're talking about upgrades so it should exist...?
 

James

Well-known member
#3
I think he's saying he uploaded the XF 1.1 files, refreshed the link he was on (/posts/89) hoping to get redirected to the upgrade page, but instead got infinitely redirected to it.
 

Jeremy

Well-known member
#4
I can't say I follow this. The only silent redirect to the install directory is when the config.php doesn't exist, but you're talking about upgrades so it should exist...?
I overwrote the config file, so I didn't have one. But it still didn't take me to the correct location.
 

Jeremy

Well-known member
#6
There was a config file in the upload package that overwrote your current one?
No. I did a batch upload, so it got deleted, without intending too. The point isn't how I got it to happen, its that it'll go through an infinite loop. I'll do the same on a development server.
 

robdog

Well-known member
#7
Just curious, but your batch upload deletes files that are not in the upload?

And this scenario was probably not accounted for. Probably should add that to the list. :)
 

Jeremy

Well-known member
#8
Hm... I can't seem to replicate this on a development server... Hate fluke things like this (but it did happen).