1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Import error (phpBB 3.0.x)

Discussion in 'Installation, Upgrade, and Import Support' started by MetalRush, Jan 23, 2016.

  1. MetalRush

    MetalRush Member

    Hello people,
    I am feeling really stupid and frustrated atm.
    Just got xenForo installed and am stoked to get our old forum imported, including the files and avatars.
    Importing is giving me the finger, tho...
    Folder structure, atm is:

    I tried it all (I think).
    With and without slashes, with and without the addition of httpdocs in front of the path...
    I read a lot of identical errors on this forum and am asking myself why this is not solved, because this error is playing up several years now...
    Who can point out my error/mistake?
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Navigate to /admin.php?tools/phpinfo and search for DOCUMENT_ROOT to get the absolute path of your XenForo installation.

    From there you can determine the absolute path for your phpBB installation.

    If XenForo is installed in the root and the software to be imported is in /archive, the relative path would be archive/, the absolute path would be something like /home/sitename/public_html/archive/.
  3. MetalRush

    MetalRush Member

    Thanks for your quick reply, Brogan.
    xenForo is installed in another subdomain.
    phpBB is on the main domain name. xenForo is (as for now) in a subdomain forum.domainname.com
    Does that matter?

    Last edited: Jan 23, 2016
  4. Brogan

    Brogan XenForo Moderator Staff Member

    If you're still struggling, it may be easier to move/copy the the phpBB directories to your XF directory.
  5. MetalRush

    MetalRush Member

    That is an option... but what goes where?

    Still wondering why the import script won't recognise my (default) folders...
  6. Mike

    Mike XenForo Developer Staff Member

    As long as you maintain any sub-directory path under the avatar/attachment directories that you're importing, it doesn't really matter where they go.

    In terms of the path, your FTP client isn't showing you the full path that actually exists on the server. Your site won't be at /httpdocs. It will be at something like /home/user/httpdocs. The specific path will vary. Brogan mentioned how to get this prefix above (DOCUMENT_ROOT). However, since your mentioned that XF isn't installed on the same domain, it's very possible that there are different DOCUMENT_ROOT values and if so, it's very possible that the sub-domain can't read the files from the parent domain (even if you use the correct path).

    In that case, the files will have to be copied to somewhere XF can read them.
    MetalRush likes this.
  7. MetalRush

    MetalRush Member

    Aaaah, now we're getting somewhere :)
    I will try your suggestion and try a new import.
    Yesterday was late (as it is now ;) ) so at a certain point I wasn't very clearminded anymore.
    Thanks for the tip(s).
    Out for a retry... will get back to report progression :)
  8. MetalRush

    MetalRush Member

    It seems to be working :)
    Importing as I am typing this message.
    Point was indeed the fact that XF was expecting the import folders in it's own (sub-)domain structure.
    Why didn't I think of that yesterday...?
    Any chance we can blame this on Brogan, Mike? :ROFLMAO:
  9. MetalRush

    MetalRush Member

    All is well: entire import was succesfull.
    Not everything is done correctly, but I will open a new thread for that, if necessary.
    Thank you both for your help/assistance (y)
    Mike likes this.

Share This Page